R6 little Bug - save changes to untitled?

Hi,

if a try to open an exist file from the hard disk after I Rhino 6 started, than I will ask to save the current default untitled file. Please disable this behavior like it was at R5.

I’m not sure I’ve seen this behavior, Micha (I’m not near a PC now, though).

Something like going to Rhino Options and clicking OK will trigger a “file changed” flag but doing nothing but opening an existing file shouldn’t do that.

I drag&drop a Rhino file from the Explorer to a fresh started Rhino only.

On my PC now and quickly testing this, Micha.
I launch Rhino 6 and drag & drop a file from Explorer. The file opens without questions about saving untitled.

Looks like we’ll have to dig deeper. Does it happen with files from any directory - on local HDD, network? Do you have start-up commands that might change something to the Rhino options?

On startup it runs: _TestToggleSubObjectSelect

I use a local HDD only. Plugins are VfR3.6 and Enscape.

I can at least rule out that _TestToggleSubObjectSelect has something to do with it. With that command in the start-up list, it still works as expected here. One of the bigger brains will have to chime in here - @brian?

1 Like

@Micha can you please disable VfR3.6 and Enscape, then start a fresh copy of Rhino? Does the behavior persist?

@brian Tested - it’s Vray. Are you in contact with the team or should I send a message?

@Micha please contact V-Ray yourself. Thanks!

Has this been solved now?
When I start Rhino 6, it comes with icons of last files opened. Clicking on the icon opens the last file but then the first question is often if I would like to safe the 'Untitled" file first. I have not worked in this Untitled file at all.

Hoi Rob - are you running V-Ray?
Please run the Rhino SystemInfo command and post the result here. Thanks!
-wim

It’s a long known bug. Disabling Vray is not an option. @Nikolay @Peter.Chaushev
Is this fixed in next? If so please port back this fix to 3.6.

Hi Wim,

No, just Rhino V6.

Plugins added:

  • Bullant
  • Section Tools

Kind regards, Vriendelijke groet,

Rob Hoekstra

seacamel1.png

Seacamel B.V. Maritime Engineering

www.seacamel.com

The Hague, the Netherlands

mob: +31 6 53 50 15 24

Not actually a bug. When you create an empty model and V-Ray is enabled, a .vropt file with the user preferences is loaded and the scene is modified. Hence the save prompt message.
Depending on what you have in the .vropt file different things might be modified, but usually the Sun is toggled on/off.

On a new file there is no scene so why is it flagged modified? Maybe not a bug in strict sense but annoying enough to bug me (for years already, I got used to it but still)
If the standard vray settings are loaded then what’s the change? There is no change. If it is not a bug then please tell me how to set the options such that I am not being asked to save my untitled.

There is always a scene. An empty document with nothing is also a scene. Just empty one.
As I said - at least the Sun is toggled on or off - in the .vropt if the SunLight plugin is missing or ::enabled option matches the default option in Rhino - then nothing will be modified. The default Sun option in Rhino might be different depending on what 3dm file template you are using.

There is a ticket about being more precise on when to set the modified flag on the document in our system, and I see it was closed early April 2018. So it is available in 3.60.03, and it is - I just checked.

V-Ray 3.xx won’t get any new service releases. Next is out :slight_smile:

Hoi Rob,
You didn’t include your SystemInfo.
At any rate, if you start Rhino 6 in safe mode and exit right away, does Rhino ask you to save?
-wim

Hi Wim,

Tried to force ‘bug’ but it is not persistent and I do not know how to force it. Anyway it happens the I click on the icon at start up.

SystemInfo is attached.

cwmwz2c2.png

SystemInfo.txt (1.96 KB)

Hi Rob - which icon?
-wim

Wow, congratulations on winning this discussion by interpreting this literally. :smirk:

Let’s bring out next (with a new set of bugs) then we can stop bothering about old bugs. Nice!