Rhino file did not save even after saving

I’ve worked on a project for hours, and every few seconds after I make a change I would Ctrl S to save, and I do receive the “save” prompt, but after attempting to render, the program seemed to have frozen and unresponsive, so I decided to why not just reset the program and open it up again since I’ve been saving my work? Well, that’s when everything went downhill since after opening up the file I was working on, it opened up the version HOURS before my LAST save. It was as if I was modeling the Eiffel tower, hit save, and then opening it up to just see one rectangle on the screen. This is absolutely frustrating, and neither of the backup files shows any versions of my latest changes on the file. Is there a reason why it did this so I can be wary of it in the future? Does rhino sometimes just not save even when you do? Thanks for any help and I apologize if this is starting to sound like a rant on the program, but I am just really tired and really hopeless.

Go back and ctrlS again, pay attention to the savein directory. Oftentimes it’s not what I expect.

I’m having the same issue here. I make changes, hit ctr+S, I see it’s ‘successfully saved as D: etc’. Next day I open the file and changes are missing! It’s the first time I experience this, since using Rhino6.
It doesn’t go wrong every time though, only sometimes. I can’t work around this, please help me solve it.

Hi Mark - Can you please run the Rhino SystemInfo command and paste the result here?

Does that mean that this is something that just started to happen? Do you remember what has changed on your system at the time this started?

Hi Wim,

I used to use Rhino 5 years ago and don’t recall any issue like this. I don’t know when this started. I have a new hard drive for a few weeks now and I’m sure it’s not when it started, I had the same problem on the previous computer as well.

Here’s the result for the command:
Rhino 6 SR19 2019-10-22 (Rhino 6, 6.19.19295.01001, Git hash:master @ 0af62045bd35259d4c2367dbf7f9ef94ded29299)
License type: Commercial, build 2019-10-22
License details: Cloud Zoo. In use by: Mark Austen ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-TEC8LEV

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro K5000 (NVidia) Memory: 4GB, Driver date: 6-17-2015 (M-D-Y). OpenGL Ver: 4.5.0 NVIDIA 353.30

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 6-17-2015
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\export_STL.rhp “STL Export”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\import_STL.rhp “STL Import”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Mark - are you saving to a local folder - say the desktop, a synced folder, like a DropBox or Google Drive, or a network?


Hi Pascal, I’m saving to local folder, my hard disc. Brand new.

Hi Mark - please try a save to the desktop - does that show up?



Hi Mark - you mentioned that the issue didn’t occur every time. Have you tried this enough now to be able to say that you cannot reproduce the issue when you save to the desktop?

Hi Wim, this happens maybe once a month and I use Rhino daily. So if that helps, I can work from my desktop for a while.

Hi Mark - check the target folders - are they Read Only for example? Or synced to a cloud account?


Hi Pascal, my folders are not synced to a cloud account, but they are read only. In fact all my folders are marked read only. It’s a Windows problem, but this doesn’t keep me from saving in them or do anything 99% of the time.

Hi Mark - probably the problem is that Rhino writes a second temp file when it saves, I have no idea but my wild guess is this is extra churn and folder access compared to other applications and that may be what Windows is choking on.

But if it says the file is successfully saved (?) and it’s not, that is something to look into.