Problem With Picture Showing All White Instead of Image (v6)

I’ve been having an issue with images imported by the Picture command showing as just an all-white rectangle. My graphics drivers are up to date, I’ve tried different kinds/sizes of images, and any new images I add show as white. I’ve also tried disabling and re-enabling hardware acceleration. For some reason, it only affects new images, not the very first image I inserted. Also, for a brief moment after restarting my computer and reopening the Rhino file, the images were all showing correctly, but that went away suddenly.

Does anyone have any insight into this? Thanks in advance.

Hello- please run the SystemInfo command in Rhino and copy/paste the results here. It might be good to make a new file, make a Picture object - if that looks incorrect, save the file and post it here.

-Pascal

Rhino 6 SR35 2021-8-10 (Rhino 6, 6.35.21222.17001, Git hash:master @ 073ac7b225c67348731c6597127b9410126c3139)
License type: Educational, build 2021-08-10
License details: Cloud Zoo. In use by: Leah ()

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LAPTOP-BJGRP394

Computer platform: LAPTOP - Plugged in [99% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 12-3-2021 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA T1200 Laptop GPU (NVidia) Memory: 4GB, Driver date: 12-13-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.91
> Integrated acclerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-13-2021
Driver Version: 30.0.14.7291
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.35.21222.17001
C:\Users\hongl\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino6.Plugin” 0.0.22102.1509
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I tried to make a Picture object in a new file, and it seems to work so far! Could it be a file-specific bug?

Hello - If you can post a file that does not look correct, I’ll take a look. here, or to tech@mcneel.com, with a link back here in your comments. It does look likely that there are more recent drivers for both GPUs, I would check the NVidia and Intel websites directly. Lastly, does it make any difference if you disconnect the external monitor?

-Pascal

Oh yikes, the new file I made started the problem again as soon as I saved it. Here it is:
ScalingDrawing_SF.3dm (239.1 KB)

It doesn’t seem to make a difference when I disconnect the external monitor. Also, I just manually updated my drivers from both the NVidia and Intel websites, but now Picture isn’t working right away in new files either.

Hello- it all looks good here - can you take a screen shot of the object’s material settings, this:

Ah - and can you please disable Enscape in Options > Plug-ins page and then close and re-open Rhino - does that make any difference?

-Pascal

Hm, disabling Enscape and re-opening Rhino didn’t seem to fix things.
Here are the material settings:

Hm - your image looks like what I’d expect - and the preview looks correct- can you please make sure you are in a display mode that is one of the Rhino defaults? It should not matter, I guess but let’s eliminate that. Also, just a shot in the dark but in the Rendering panel, scroll down to the bottom and click on ‘Reset to defaults’ - does that do anything good?

-Pascal

I’ve been in Wireframe mode, but I also switched around the other modes to check if they changed anything, but they didn’t.
“Reset To Defaults” didn’t change anything as far as I could see.

It’s very strange, sometimes I can see the image when I open a new file and drop it in, but as soon as I do anything like save it or paste in some objects from another file, the image goes all white.

I really appreciate you working with me to try and fix this, though.

OK, thanks, I’ll have to check with some bigger brains.
@hong_eah - can you run SystemInfo again so we can verfity new drivers are in place?

Please see also:

-Pascal

Rhino 6 SR35 2021-8-10 (Rhino 6, 6.35.21222.17001, Git hash:master @ 073ac7b225c67348731c6597127b9410126c3139)
License type: Educational, build 2021-08-10
License details: Cloud Zoo. In use by: Leah ()

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LAPTOP-BJGRP394

Computer platform: LAPTOP - Plugged in [99% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 5-13-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA T1200 Laptop GPU (NVidia) Memory: 4GB, Driver date: 5-5-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.78
> Integrated acclerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-5-2022
Driver Version: 30.0.15.1278
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.35.21222.17001
C:\Users\hongl\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino6.Plugin” 0.0.22102.1509
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

That post was a good thought. I checked, but my graphics settings were already set to High Performance, though, so that doesn’t seem to be it.

Hi -
Did this used work correctly on that system or has this always been like this?
We’re running out of ideas on this one. I’d make sure that Windows is up-to-date with all updates and then do a clean install of the GPU drivers following this recipe:

Make sure to include step 4 of the uninstalling process!
-wim

What happens if you UNCHECK “Self-illuminated” and “Use alpha channel” ?

Also, what happens if you draw a plane object, and then assign a material to it that uses the texture “siteplan.png” as the Diffuse channel texture and then go into Rendered mode?

If the latter doesn’t work, then does any texture file work ? In other words: Do all texture-based materials look white, or is it only “Picture” objects that look white.

-J

Thank you both for your comments!

@wim I haven’t used Rhino very much on this device, but it did use to work from the brief times I’ve used Picture before.

@jeff I tried those suggestions and it looks like only “Picture” objects look white. Other textured materials render fine.

So creating a material using the exact same image file as your Picture object and assigning it to a plane works as expected?.. Just confirming…

Did you try unchecking the options I mentioned in the precious post? It sounds like something is incorrectly (post)processing the image when it’s being read in as a “Picture”, and creating incorrect material settings… unfortunately when I view your file here, everything looks as expected.

I have attached a file (modified from yours) where there is a Picture object on the left, and planar object on the right… I have created a material that uses the same image as the picture and assigned it to the planar object… I then used “SetObjectDisplayMode” to set the planar’s object display mode to “Rendered” so that it displays the texture in any display mode (which is pretty much what happens internally with Picture objects).

Load the file and tell me what you see…

Thanks,
-Jeff
PictureVsPlane.3dm (547.6 KB)

Yes, unfortunately, a material using the image file reads just all-white.
I did try unchecking the options you mentioned, but they didn’t do anything I could see.

Is it possible for you to save your file as a Rhino 6 file? I’m afraid I can’t open a v7 file.

Sure… sorry I missed that…Here’s a V6 version… I created it from scratch just in case V7 does something different.

-J
PictureVsPlane.3dm (635.3 KB)

Thank you!


Huh, seems like I can see the images in your file just fine (I’m kind of trying things to see if they’ll suddenly go white like I’ve previously experienced). When I open my original file, though, it still looks white:

Edit:
Oh, this is strange. When I “Picture” in the same image from my device, it still shows as white in both your and my files. When I use a different image, it’s inconsistent, but usually appears as it’s supposed to (in both files). It seems happiest using the images already in your file’s Embedded Images folder.

Actually, now I’m wondering if it’s something to do with the cloud image files. I use a lot of images from a Google Drive folder using Google Drive’s desktop app, but so far it seems like images that are directly from my device work more consistently than images from Google Drive.