Picture Frame is black

I am trying to load a picture frame on my new pc but I had no luck.
My old pc with an hd 4000 graphic card can open it quickly and with no problem while my wacom companion with iris pro 6200 is showing just a black img.
under options- open gl I can see the video memory available is higher for the Hd 4000 compared to the iris pro , is this parameter correct?
How can make the img visible? ( RGB jpg)
Thank you for your help.

Hi Nick - I guess the first thing to try is to make sure your video drivers are the latest - a new machine will likely have drivers that are not the very latest.


Thank you Pascal,
I made a check and they are the latest.
Unfortunately it didn’t work for me.

Have you any idea on what could be the problem?


Hi Nick,

As a temporary workaround you could try and see if disabling accelerated hardware mode will render the image visible?


Hi Willem, thank you for your reply,
yes it does but the image quality is very poor…


Hi, is there anyone from McNeel who can tell me how can i fix this problem? The iris chipset is clearly superior than the hd 4000 and the texture resolution is two time higher too. same story for the memory available and the video memory so i wondering why on my old pc, rhino can easily manage this image that i can’t open in the new one.
I am also having problems with clipping plane and render mode display( it is fine in shaded ): the clipping plane is showing parts of the model and hiding the others ( they are all on the show side).

Thank you.


What is the size of the image you are using?
Did you try using a smaller copy of it?

Thank you Brenda, I did but it only works if I drop the res.
The file is about 8 MB but in any case on the older it works just fine, so i don’t get why isn’t working on the pc with the latest chipset, moreover it take some times ( 2-4 sec) before it allow me to set the picture frame ( that appears as black).
Being a topographic elevation I need to read the figure on the image

As a temporary workaround, perhaps you could section it, and align the sections. In other words split it into say 4 images, and then panel it together in Rhino.

Thank you Brenda it worked if only go lower than 2000x 3000. it is a workaround definitely but if i think i have to model 15 topographic map like this…
but really that was a good idea.
still hope the someone from McNeel would be able to tell me how to fix this and the clipping plane issue too.

Hi Pascal,
I would like an help to fix this issue.
A temporary walkaround was suggested by Brenda but now I would like to hear how to fix this issue. i can’ t simply accept the fact rhino performing better on my old pc with lower hardware specs.
Moreover I can easily manage this file with others 3d modeling software so there must be something i am missing here.
Please help me.



i’m using (6.0.17355.10131, 12/21/2017) on a Surface Pro with latest display drivers and i’m running in the same problems. if the pictures get to big (couldn’t find a max resolution, filesize seems not relevant because pngs < 1 MB aren’t showing, jpgs > 1 MB do…) they don’t show.

This is realy frustrating, since this was my last fallback method to import some external data that dosen’t work with dwg (nested blocks turn and position awkward) nor pdf (no text, see my other post).

This bug seems more than 1,5 year old, the pdf-import bug isn’t much younger…
if rhino doesn’t get the import and export fixed soon, this software isn’t usable for me.

best regards,

@heiko.woehrle, Can you attach an image that doesn’t work for you?

Hello all

I’m having a similar problem to all of these previously posted in 2017. Some pictures will import fine in rhino and others won’t. I need to trace an image so I need to see it in a normal display mode, but it only shows black. I tried reducing the resolution of the image, but it didn’t help. The image shows as a texture in the material menu and as a render, but it won’t show in a normal display mode. I also tried the -pictureframe and reparameterize commands from other posts. Any ideas? Thanks!

Hi - which version of Rhino 5 are you running? Could you attach one of the images that doesn’t work and a screenshot of your OpenGL settings (Rhino Options > View)?

Hello! You probably found a solution but for anybody who might be looking -
I was having the same problem. Here is what I did that helped me:
I opened the image in Photoshop and scaled it to Width : 4.3" & Height : 3.6". (You might try to keep the image at 4.5" Wide, varying Height based on your image)
Switched to RGB color and saved the file as jpg. The new file size is 120KB instead of 84MB and could be opened correctly. I think my previous file was too large and resulted in a black screen, and the image was only visible if I hit the render view. All my drivers are up to date and I am running the latest Rhino version.

In case you do not have Photoshop, you could possibly use Paint to do the above mentioned steps.
Good luck

I wouldn’t be surprised if the 84MB image file just didn’t fit in GPU RAM with all the other stuff already in it. Just guessing though.

Thank you both for the response. Yes I was able to solve the issue by lowering the pixel count in image paint. Thank you again.


just click the View>Technical… and it will be fine