Printing Technical Drawing - Adjusting hidden line scale

unhandled

#1

HI,

I made a layout view of my model and used Technical display mode becuase our customer wants to be supplied a 2d blueprint…and because I am trying to get away from Autocad. I can’t seem to get the hidden lines to look decent. Is there any way to clean this up without using the Make2d Method?

Thanks,

-Brandon


(Pascal Golay) #2

Hi Brandon- not that I know of.

-Pascal


#3

I am resurrecting this ancient thread to see if this has been improved in Rhino 6? I am currently looking at purchasing Inventor or solidworks because I need to make nice looking blueprints from my models. I just remembered Rhino 6 is released and I would much rather upgrade Rhino. I Currently have 12 Seats of Rhino 5 and would like to continue to use Rhino for CAD/CAM if possible.


(Wim Dekeyser) #4

Display, in general, has been improved (and so has Make2D) - but not anything specific for the technical display mode. There’s only one person who will be able to tell us if it is good enough - you. Download Rhino 6 and give it a try…


#5

Just downloaded it. Trying now.


#6

Welp… Looks like I have to open my wallet a little farther to get a nice looking blueprint. I purchased one upgrade license to give this a try and it brought back a lot of memories as to why I went back to Autocad.
I installed Rhino 6 and dug up the same print I posted here 4 years ago. The hidden lines look better, but the line thickness is huge for a solid line. Keep in mind this is an ‘A’ size print that I printed to PDF at 2400DPI and zoomed in on this area for the screenshot. I set every layer’s print settings to hairline and also specified that in the print options. While the hidden lines look a little better, I still don’t see any options to adjust the linetype scale of the dashed lines? Sometimes it looks too fine or too coarse and it is nice to adjust. I can get a decent print with Make2d, but that breaks the association with the model which can make revisions a pain.

As far as the memories it brought back… The buggyness of trying to print to PDF. The first time I loaded the file I could not get the title block bitmap image to show up on my screen or my print ( yes I had background bitmap checked in the print options) . Then the program crashed while trying to print to PDF. After I loaded the file back up my bitmap image appeared and printed fine…but… now I couldn’t get my dimensions to show up on the PDF. All my layers were turned on and it even showed them in the print preview. I must have tried 10 times adjusting different settings with no luck. So I saved the program, shut down rhino and rebooted my system. Fired Rhino back up and the dimensions printed fine again. What a headache! I remember going through these same kind of issues with Rhino 5.

Don’t get me wrong, I love Rhino and sing it’s praises to anyone who will listen, but it really lacks in this department. I really don’t want another CAD system but I don’t have much of a choice. I need software that can generate a nice blueprint directly from a model.


#7

I also took this file home and tried to print on my new rig which has a GTX 1080-TI graphics card, just to be sure it wasn’t a problem with the intel HD 4000 graphics on my work computer. I had the same problems. Even the mysterious disappearing/reappearing bitmap image for my title block. :sob::sob::sob:


(Wim Dekeyser) #8

Don’t worry - I agree. I’ve said numerous times before that making production drawings in Rhino just isn’t productive.

At any rate, it appears there are several issues going on here and perhaps they need each their own topic?

  • PDF printing: which PDF printer are you using: The new Rhino 6 one or some external one?
  • PDF printing crash: are you sending in crash reports?
  • Printing Technical display modes - I wouldn’t think that setting layer’s print width settings have an effect. I could be wrong though… You are basically only printing a picture, not lines.
  • Line thickness. Try the testWireThicknessScale command and see if that helps. (see link to thread below for more info).
  • Dashed lines sometimes being too fine, other times too coarse - a 3dm file would really help trying to figure out what you mean here.
  • Title block bitmap not showing up. Dimensions not showing up. Perhaps not as much for the HD 4000, but for the GTX, are you running up-to-date display drivers?

CC: @stevebaer


#9

I have tried the Rhino 6 pdf printer ( The one that just says ‘PDF’ ) , cute pdf and Microsoft print to pdf. I have mostly used the Rhino PDF and I submitted a crash report.

I tried TestWireThicknessScale and it looked different in my viewport, but appeared to make no difference when printing to pdf.

As far as the dashed lines go, I am talking about the linetype scale. How long each line segment is and how much empty space is between each line segment. I don’t see any controls for this when using ‘Techincal’ view in a layout.

My display drivers are up to date.


(Wim Dekeyser) #10

That’s correct - there are no controls for this.
And the official word is that technical views are not meant to be used to detail products:

Perhaps detailing will be looked at for Rhino 7…


#11

I understand mechanical drawings is not Rhino’s focus. It’s a bit frustrating though because it’s so close to what I need but it’s missing some minor details. It’s seems a bit illogical to me to have to break the association to the model by using the Make2d command? Personally, I find it time consuming and risky from a manufacturing standpoint. I have seen people make changes to models and forget to update the blueprint, or make an error when updating the blueprint which causes the model and blueprint to be mismatched. These errors can wreak havoc on an important project with pressing deadlines.


(Steve Baer) #12

I agree. We are headed in the direction of automatic make2d type drawing generation for future releases of Rhino and the rewrite of Make2D was one of the steps along the way.

Let’s look at the current batch of bugs you are seeing. Do you have a file you can share that exhibits the overly thick linework problem?


#13

That’s great… but I’m sorry to say that I really thought that this feature would (should?) be in V6 already. I’m sorry for sounding so negative, but this is such an important feature (for me). I’m still exited for V6 though (as soon as we get on OS X) :grinning::+1::sunglasses:

Philip


#14

@stevebaer - attached is the file but altered a bit and removed customer info.

test2.3dm (1.4 MB)


#15

This is the pdf I just generated from it. I can’t get the dimensions and title block to show up again.

Just restarted Rhino and tried again. No dimensions or title block. Rebooted my computer and it they showed back up. This happens on my work computer and my home computer.

test.pdf (738.6 KB)


(Mail) #16

I have this same problem- super thick lines. It only happens in Technical setting not wireframe etc… but I don’t need a 2-D wireframe. I tried linetypescale in paper and model space and that didn’t help either.


(Mail) #17

I also have tried different PDF programs and experienced the same problem with output thickness. However with the problem of spacing of dotted lines, that can be modified in “pattern” on your screen shot. the underline is for what is seen and the non-underlined is for the space, so you can type in the size of the linetypescale there. does that answer your question?


#18

No, It does not seem to apply to the hidden lines in “Technical” type views. This also does not affect the spacing on my Layout nor does it affect the spacing when printing my layout.