Pdf from new Mac Rhino in Beta Catalina

Running Catalina…from the print menu…attempting to save as a pdf … get Error while printing (did this several times). Also tried Save as adobe pdf–nothing happens, not even a error message. Did find a work around–open in preview and then export to pdf. Thoughts?

@dan FYI

Hi @debbooth-

Thanks for reporting this.

Unfortunately, I’m not able to reproduce this on my Mac. Here is what I’m doing:

  1. Launch Rhino 6 for Mac (6.18.19266.13352) running on macOS Catalina 10.15 Beta (19A573a).
  2. Start a new modeling window.
  3. Run the Box command and draw a box near the origin.
  4. Navigated to File > Print….
  5. From the Print dialog, in the lower left-hand PDF drop-down, selected Save as PDF
  6. In the Save sheet, I changed the title to Test.pdf and set the Where: to my Desktop and clicked Save.

Test.pdf appears on my Desktop and shows a box.

What are we doing differently?

-Dan

Hi Dan,
Basically I did the same.

  1. launch Rhino 6 for Mac running Catalina 10.15
  2. tried with a file I was working on
  3. Navigated to file print and same
  4. print dialog–drop down save as pdf–get that error message.
  5. Also did what you did opened a new window, tried the same, same error message.

The error while printing come up over the preparing to save window almost immediately each time.
Also tried save as Adobe PDF – nothing happens, no error message and no file
Also tried save as postscript–error message

Hi Dan,

I downloaded and installed again–and everything seems to be working now. Perhaps I had a corrupt file.
Thanks for being so quick with the response and I really like this mac version–great improvement! Wow.

1 Like

Hi–its me again. The problem has returned. It worked fine one time after I reinstalled but since then…same problem, same error message Error while printing. As I said, I can work around it by going to preview and exporting as a pdf–just adds another step.

Hi @debbooth I am having the exact same problem. Were you able to find the source of the problem or a solution ??

You’re probably NOT running an old Beta Catalina.
Please run the SystemInfo command in Rhino V6 and post the results.

Thanks

Rhino 6 SR21 2019-12-15 (Public Build, 6.21.19349.01012, Git hash:master @ a9aff0b2a2e07411210fef500868737069a15926)
License type: Evaluation, build 2019-12-15
License details: Stand-Alone
Expires on: 2020-03-10

Apple Intel 64-bit macOS Version 10.15.1 (Build 19B88) (Physical RAM: 4Gb)
Mac Model Identifier: MacBookAir7,2
Machine name: Maria’s MacBook Air
Language: en-US (MacOS default)

Intel® HD Graphics 6000 (OpenGL ver:4.1 INTEL-14.2.16)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel HD Graphics 6000
Displays: Color LCD (126dpi 1x)

Graphics processors
Intel HD Graphics 6000 (1536 MB)
Color LCD (1440 x 900)

USB devices
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Broadcom: Ultrathin Touch Mouse, Ultrathin Touch Mouse, Ultrathin Touch Mouse

Third party kernel extensions
com.avg.FileShield (4.0.0) C704FE1C-8573-360B-A302-381D62483609
com.avg.PacketForwarder (2.1) 9A7FE361-ED85-3583-8688-7536F04415A2

Third party plugins
/usr/lib/log/liblog_network.dylib

Rhino plugins
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.21.19349.1012
/Applications/Rhinoceros.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 6.21.19349.1002
/Applications/Rhinoceros.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.21.19349.1002

Correct, my Catalina is not Beta. What can I do?

Mine seems to be running fine now making those PDFs. I was so used to opening in preview and then making them, I forgot to check. I am running a Beta Catalina…not an old one–but current version 10.15.3

Ok, spoke too soon. It still fails. So clearly there is a problem. It could be the Beta Catalina-- but for now I will do the work around. It’s a pain, adds a step but unless someone has a better solution?