Cannot print to PDF

We are running the latest build of Rhino for Mac on several MBP 16, and cannot print to PDF. This is the case across all our 3dm files, regardless of save location, we get the error ‘PRINT. Error while printing.’. The only workaround we have found is to open in preview from the print dialogue, and then save from preview as PDF.

Does anyone know what might be causing this issue? I am happy to upload a file here if that helps, but I don’t think it’s anything we’re drawing - as I can recreate the same issue by creating a new file, drawing a single polyline and trying to print to PDF.


Hi Simon - I moved this post to a new thread as that old thread was about Rhino 5.

Can you confirm that this is on Rhino 6?

Just to make sure, are you saying that “Save as PDF” from this menu doesn’t work?

I have this too. Only way to save to PDF is through preview. Running Catalina 10.15.4 Beta

1 Like

I’m running Mac V6.23 under Catalina 10.15.3 on a MBP 16,1
Just as Wim shows, I can print to PDF from a model viewport or a layout.

Hi Wim,

Sorry for the slow response. Yes that’s all correct, Rhino 6 and we are trying to use the save as pdf drop-down as you show.

I can recreate the issue in any file on any of our machines. However, I just tried to re-run this process now from a random file (that i’ve never printed from before) in order to screenshot and share. It worked as it should, and saved straight to PDF. But as soon as I changed the settings to match what we would normally use: A1 page size / Window / Vector output / Print colour / 1:100 scale; then the print error returns. Now whatever I do to the settings I get the same error - even when i revert back to the print settings that first worked (A4/Viewport/Raster/Display/ToFit).

Thanks for any help

Hi Simon - I’ve now tried to reproduce this with the following settings:

but that seems to work fine here. Could you post a 3dm file?

Hi everyone! Just wanted to let you know that I solved this issue (I hope it will still be working tomorrow though haha). What I did was I opened System Preferences > Printers & Scanners, i then selected the printer (the one you later select when you open the printing window on rhino) and pressed Options & Supplies. There you should check the checkbox that says “Use Generic Printer Features”. Restart Rhino if it is still open and it should work.
Hope it works for you guys!

Good luck!


Hi -
Thanks for that information.
Note that another possible way around issues with printing to PDF is to use the Rhino PDF exporter (and not the MacOS exporter). On Mac, currently this is done by using Export or ExportAll and then exporting to the PDF format.

Hi. Thank you very much for your message.
I had a same problem about saving PDF, and I could make it work with your idea.
It was really fantastic, Amazing!!

1 Like

Thank you for this. It also helped me to solve the same issue.

I am also having all sort of trouble with rH8 print to PDF

error log file below:

%%[ ProductName: Distiller ]%%
%%[ Error: ioerror; OffendingCommand: imageDistiller ]%%


%%[ Flushing: rest of job (to end-of-file) will be ignored ]%%
%%[ Warning: PostScript error. No PDF file produced. ] %%

Is that printing to Rhino PDF?

Hi @Helvetosaur - yes i have tried both Rhino-PDF and also Adobe PDF. It did 2 detail tabs perfectly, and the last 4 it just max’s rhino and the screen goes blank after about an hour. Insane

Can you post the file in question here? Or if not, can you upload it to tech support here with a link back to this Discourse thread?

sure thing - thank you so much I really appreciate your help @Helvetosaur

pdf (19.8 MB)