No Acknowledgment nor Feedback for Bugs or Fixed Bugs?

Dear McNeel Staff, people use a good amount of their time to report issues they find with Rhino, issues which they do not just report because they are bored but because they are truly important.

i have seen @brian regularly reporting back with fixed issues which is great and i think is the absolute minimum you guys could do to let people know when it is fixed, but not even acknowledging an issue like in this topic which was created one and a half years ago after several people where putting quite a lot of energy into it and then silently just dropping a fix for it without even letting anybody know that you are working on it is just absolutely beyond my comprehension.

here the silent bugtracker

i have noticed that a few times in the past and i have complained about it at that topic, right now i am though happy that this specific issue was taken care of but pissed because nobody ever got back with it.

can somebody explain what is going wrong here? can we please have a more thorough communication? if you trying to demotivate people buy just ghosting their efforts… well that is how you do it.

You understand how many reports they get? They’ve never personally acknowledged every single one, and whether they do or don’t has little bearing on when or if it’s ever fixed. You want the group cluttered up with a bunch of possibly automatic soulless boilerplate messages? This is the official place to report issues, they are all read.

1 Like

are you are robot? or are you some AI or are you becoming one of these?

i am not even talking about a minimum of interpersonal relation, neither hoping for a handholding thank you each time i report a bug, but not knowing if a problem has been even understood and having no idea if one can ever use rhino in these regards again while somebody went actually ahead and fixed it eventually, is definitely not an unreflected egomanic idea.

@JimCarruthers and anybody reading, the reason why i am so messed up this specific time is because i was literally begging for this problem to be looked at for a long time since it is a very big issue. not being able to communicate with company standard and other standard-fonts having to resort to either using Rhino 5 which i have not installed anymore, or using a layout app which made it really complicated having to toss to and fro fonts so that they show up in 3d space as needed is just absolutely staggering. too much effort for something so essential.

a couple of month ago @dan showed up stating that he did not understand the problem at which point i was almost giving up but pulled myself together to make one last thorough explanation, then again nothing no response no acknowledgment i had no idea if it was taken serious, if it was understood, or if somebody even looked at it because my posted files where untouched. then yesterday an update pops up which i thankfully-usually read through as thorough as i can and find out that this problem has been taken care off. so eventually dan must have reported further that issue.

i am not blaming anybody, i am aware that there is a lot cooking, but that should have been very clear that people are desperate about it, and a usual ok got it (with the usual youtrack link) would have been really helpful not letting people in the dark and then just silently dropping such an essential fix…

i had not thought that this will ever happen since the problem seems to exist since Version 6 of Rhino.

so guys please please with cream and a cherry on top, communicate some sort of acknowledgement

Hi Richard-

I replied in that topic. I’ve spent hours trying to reproduce the issue, including enlisting others inside McNeel. We could not. Despite that, I believe you and I agree it is likely a bug. It is not off my radar and I did see your additional information. Unfortunately, other issues have taken higher priority.

I’m not sure what else I can personally do to assure you that it will get more attention.

Update: it looks like someone might have fixed it based on the YouTrack issue you posted. That report came in from a different source than Discourse from the look of it and we did not connect the dots.

Did you test the fix?

Did it work?

hi Dan, did you try googles roboto as pointed out? that still does not work, so i have no idea what got fixed actually.

update: ok now i see, it was one specific font which got fixed, but still quite a few important fonts remain, so the issue is unfortunately not generally fixed yet.

This goes both ways. Conversation takes time and effort. It’s hard to write clearly, communicate clearly, diagnose everything, and reply perfectly. Sometimes we start working on things only to find we can’t fix them. If we were good at doing what you’re requesting, we’d also need to get good at commenting when we move on to something else without resolution.

Sometimes I pick up a bug for a few hours, and then realize I can’t fix it, and put it down. If I were to post here after picking it up: “Good news, I’m on it…” and then forget to tell you I gave up, you’d have some pretty different expectations than me.

I guess I’m just saying that communication is hard, and we’re not perfect at it. That probably won’t change.

1 Like