My Rhino 7 project won't let me select anything or save (PLEASE HELP)

I’ve been working on a Rhino project for several hours now and have been inputting pre-made models into a build then matching the materials across so they’re all cohesive. Whilst trying to match one such material the program just froze and had the command ‘select material to match’ in the command box but wouldn’t allow me to select anything on screen. I now can only move around the workspace but cannot select anything or even save. All my layers are unlocked, so I didn’t lock them by accident. Please help.

Hello- is there a dialog someplace, maybe hidden by another window?


I dont think so, apart from Chrome, Rhino is the only program I have open and its only showing one active window

Can you Save?


no. i can click the ‘save’ and ‘save as’ button under file but nothing happens

What does the command line say, anything?


its currently blank
i can get you a s.s of the past lines if that might help??

Yes, please.

It was about where the blue arrow is that stuff started to go wrong

@johnc - do you have an idea what might be happening?


Can you type save or saveas on the command line?

Have you used alt-tab to see if there is a dialog somewhere…? It looks like it’s still trying to save…

by dialog, what do you mean by this? i’m new to rhino so I’m not sure what i’m looking for

I’ve tried this but it doesn’t work. I’ve also tried just closing the program normally and trying to load up a save but it wont let me even close the program. I’ve not tried force quitting it yet though as I was hoping to find a solution without having to redo some of my work

Well it’s not a Rhino thing it’s a Windows thing…press alt-tab and see what all the options are, if there’s a dialog box on its own or something…it seems to all the world like it’s just waiting on some input…

The only two windows I have open are rhino and chrome. nothing else, no dialog else where. rhino wont allow me to input anything so how can it be waiting for an input it wont accept? If thats what youre saying, is my best case to just task quit the program? and if so is there a way to reload an unsaved file from task quitting it?

Jim is suggesting there may be an open Rhino dialog which has got shifted off the visible screen area so you aren’t aware of it. Alt-Tab is a Windows command that cycles through all your open apps and may bring that dialog back into view.

Note that this no longer works in Windows 11 - it cycles through the apps but not dialogs (one of the many “improvements” brought to Windows in that release).

If you are on an earlier version of Windows, give Alt-Tab a go - you’ve nothing to lose by it.


I’ve done alt-tab and, like i said previously, there are only two applications open; each with one screen. no other dialog boxes or screens or anything.

since you are prob working with all the default settings… then your .bak file should be safe…

check you working folder… where your file is… and open rhino… but open the .bak … backup file…

should be current to the last autosave… has saved me in the past…

1 Like

Thank you. The .bak file was further back in my progress than my last manual save, is there a way to access a more recent one or is that it?