Save acting like Save As

Anybody else getting the Save As window when you hit Save? It is happening over and over again but not always.

Here’s my info:

Rhino 6 SR20 2019-11-18 (Rhino 6, 6.20.19322.20361, Git hash:master @ f60ce76e397bba419469ae5277fc1578641caa3a)
License type: Commercial, build 2019-11-18
License details: Cloud Zoo. In use by: Cosmas Demetriou ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-7SR0TFT

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 10-16-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 440.97

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-16-2019
Driver Version: 26.21.14.4097
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Users\Cosmas Demetriou\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\OctaneRenderForRhino (f109bd23-4cf3-4c0b-9f83-06be474b0152)\4.5.0.111\RHI Installer 6\Rhino 6.0\x64\OctaneRenderForRhino.rhp “OctaneRenderForRhino” 4.5.0.111
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

Does this happen with a new file, or are you opening a file last saved in V5 or some other version of Rhino?

Hey John.

No - it’s neither a new file, nor one last saved in V5. It’s a V6 file - 619 mb :frowning:

Thank you.

I don’t understand it.
Do you have any extra plug-ins installed?
You might try temporarily disabling them to see if that make the issue go away.
Have you restarted your computer recently?
I’m guessing here.

Thank you, John. I’ll do that and get back to you. :slight_smile:

Good morning John,

I am still experiencing this behavior. I hit Save and get the Save As dialogue. The only plug-ins I had were the Octane renderer and the driver for the 3d Connexion mouse, which I have turned off. Is no one else experiencing this?

Hi Cosmas - is this a set of steps that will reproduce the problem in your case:

Start a new file.
Make a box
Save the file to disk
Add another box.
Save.

?

-Pascal

Good morning Pascal,

No—the Save to Save As strangeness does not happen all the time and does not happen when I follow the below but it happens a lot with one particular file which is too large to upload. Any other thoughts? :blush:

Hi Cosmas - is the file last saved from V6? any blocks? Can you upload to www.rhino3d.com/upload, to my attention?

–Pascal

Hey @Pascal,

Just checking to see if you got my file yesterday and if you were able to see the behavior? It’s still happening over here and now in other files as well :slight_smile:

Thank you.

Hi Cosmas - the file named FR_ etc etc, correct? I am getting it now. I guess if you want me in particular to see uploads, stick my name in your comments or use my email in the target email. (tech@mcneel.com is the default) It looks like you also had a failed upload - is that the same file or a different thing?

-Pascal

Hi Pascal,

I just tried to call you. I thought I had put your name in the email field (pascal@mcneel.com). Strange. At any rate, though, Pascal, regarding the failed upload – it’s a different file that I sent you this morning that is also doing the same thing (Ctl+S brings up the Save As dialogue). I tried to upload it 2x and I kept getting a failed server message. I have been running in to this for years :frowning:. Wondering what could be causing it? It was a 165 mb file compressed in to a 115 mb rar file – and it still wouldn’t go through. Any thoughts on that?

Thank you😊

You are not alone, if that is any comfort…
Save behaves normally, here, with the file you sent… from V6, but as expected, prompts as SaveAs if saved from V7… does that make any sense with what you see? (V7 contains information that V6 does not support)

-Pascal

Hi Pascal,

When you say “you are not alone, if that is any comfort” are you referring to the failed uploads? Is there a workaround for this? – When we can’t upload our files?

And as for SaveAs coming from V7 – I do have V7 but haven’t used it in this file. It’s no biggy – I can keep using the Save As dialogue and just overwrite the file name that it navigates me to but as a good Rhino citizen, I wanted to put it out there😊

Yep…

None that I know of, I’m afraid.

At any rate, I’d like to pin down the problem you’re seeing - if you can, please note, as best you can, what you’ve done when next you see this happen. My guess is user data from plug-ins may be involved but that is speculation.
In fact, if you get this situation, cancel and Audit3dmFile the currently open file, the SaveAs and Audit3dMFile the result, and send me the output from both audits… that may tell us something.

The Municiplaity thanks you for being a solid Rhino citizen…

-Pascal