Move walls with windows

Hi everyone !

May I extend my question of last week ?

So now that I can change the wall type, with a thinner wall, I need to replace the wall to its correct position.
Walls and windows are modelled in Revit.

Based on this topic, I did the following:

The wall in Revit is the input; moved the Location Curve with the orientation vector and a factor; and then use this curve as input for the Element Curve component.

As you can see in the errors, the windows are deleted as thy cannot be placed because they “do not cut any other objects”.
I also tried to moved the windows, in parallel, with the walls…

Am I doing something wrong here ? Or is there any fancy trick ? (;

Thank you very much in advance ! (:

Aurelius (8.3 KB)

Maybe as a complement: if I place again a window after I moved the wall with gh, the definition then move the wall and the window.

You can set the wall into a new Location or set the wall Curve as an offset of the current wall curve.

Thank you for your help @kike !

Sadly, I get the same error messages, in both cases.

What happens if you move this wall in Revit UI?

Does it work?

Yes it does, that’s why I assumed it could be possible (:

What version of RiR have you installed?

Can you share a screenshoot of what we are trying to offset?

Thank you for taking a look!!

Rhino.Inside Revit: 1.6.8159.20547 (2022-05-04T11:24:54)

[Expanded Information]
Rhino: 7.18.22124.03001 (Rhino 7)
Revit: 2022.0 (
CLR: 4.0.30319.42000 (4.8.4300.0)
OS: Microsoft Windows NT 10.0.19042.0

And here’s the wall I use for testing. It’s a part of a bigger building.

Please place a wall of the same wall type isolated from the building and a window of the same window type on that new wall, and then try with it.


Exactly! When I redo the exact same next to it, it works perfectly !

Maybe something relted to worksets or phasing??

Are original wall and windows on the same workset and phase?

Phase and worksets are the same.
The only difference I see, is that the new wall doesn’t have a paramter “ifcGUID” yet…

I don’t know exactly whats happening but to me looks like windows are not moved when the wall is moved.

Maybe windows are locked?
Or any other reason that prevents those windows to move?

Very likely ! Even though, I can move them in the Revit UI