Lost customization in a Factory Reset

[link to the relevant thread ]

Yesterday I was helped to solve a problem. The problem was happily solved.
But during that process, I was asked to do a Factory Rest [which is obviously commonly needed to find problems.
As per the instructions I saved the Window Layout file, and the support Zip file.

Upon restoring my custom setup. I seems to have lost quite a few things, some I don’t mind because they are easy to redo… [colors, and all sort of options settings that were lost]
But I also lost all the custom keyboard shortcuts. and this is a bit of a biggish problem as it will take a few good hours to manually redo all of these [unless hopefully someone can please show me a way to restore the keyboard SC from the zip support file…?]

So apart from the need for help here, I wish to ask the Mcneel support and devs, to please fix these gaps in the saved customization !

And until this is done, and everything, Everything is saved in one file.
Kindly create a detailed instructions that cover all the parts that user can customize.
Please consider each user on every reset request, as someone who did heavy customization [even if he/ she did none…].
Consider composing a comprehensive instructions and simply attach that to any reset request.
And please let us know what is not [yet covered/ restorable]. are there work around? and if not, we need to know so we can make a choice regarding following the reset request.

Thanks a lot
and apology for the frustrated tone.
With best regards
akash

hi @Akash can you send me the support zip file you created? AFAIK that should contain the things you want to retrieve
edit: did you by any chance also run _OptionsExport, before _Reset?

Thanks @Gijs

unfortunately not… that is part of why I wrote this frustrated rant above.
That it is really important to explain to us how to backup everything before asking us to reset.

Q : does the support zip contain any private info? or can I add it here? [it’s 21mb ]

pls send by pm to be safe. I might have a way to get the shortcuts back, but not sure yet

thanks @Gijs

Discourse won’t let me [max is 20 and the file is 21]
I’m uploading to support

Ok, taking a look now
edit: pm sent

@Akash, that is, I think, the politest rant I’ve ever read. And excellent sentiments.

Hi @dan

I really need to restore the lost pref. from that reset.
Some month ago you helped me trick
rhino to use an old pref file to restore after an unfortunate WIP update.
I’m trying to do the same now, but no luck so far, [it is also a bit confusing…]

That’s the thread where you helped me regain the pref. [I have a TM backup from which it should be possible to get the pref.]

thanks a lot
Akash

And it’d be super helpful if somebody (ANYBODY) could explain where this stuff gets saved, how to export it, and import it, particularly the custom menus as I have to go through insane gyrations on every launch to get them to show up (essentially you have to add a new custom menu and open and close the dialog a few times for them to show up, then go back and delete the newly added one).

They’re obviously in there as eventually they WILL show up with enough trips to the menus dialog but for the life of me I have no idea where.

I’m still working through the backlash of stuff I’d added R7 over the past couple years as I run into stuff I’d put in and find it’s no longer there, which run all the way from little macros, KB assignments, aliases and other stuff all the way to full python scripts.

There is no need to apologize. It’s us who need to apologize.

I really hope there are no gaps in saved customization, but I suspect there are in some rare cases. Where there are gaps is in our support materials and documentation for this new system, especially on Mac.

Everything ought to be saved in one folder:

/Users/~/Library/Application Support/McNeel/Rhinoceros

The folder that Rhino uses for all the settings is the one with the version number, for example:

/Users/~/Library/Application Support/McNeel/Rhinoceros/8.0

It is my sincere hope that we actually did backup all your settings and you can find a folder called:

/Users/akash/Library/Application Support/McNeel/Rhinoceros/8.0backup 2023-11-17-11-05-00 or similar that contains your old customizations. The folder name should correspond to the day you reset.

Is there a folder like that there? :crossed_fingers:

Hi @dan
Yes that folder exist.
And I did look at this, and tried to restore from there after the reset.
But I didn’t find a way to use the setting .xml files… I think @Gijs also tried and he was able to extract a partial list, to manually copy from. but not a way to just use the file to restore settings.

My Error was that before resetting, I looked for the command ExportPreference. and since I couldn’t find it… I assumed it has been incorporated into the saved Window layout or the save support file. But as I learned too late, the name has been changed to OptionExport. [Which unfortunately didn’t show up in the suggested dropdown when I typed export in the command search…

So
Yes, especially to Mac users, the UI change are so big, that even as I followed the WIP and Beta fairly closely, there are still lots of unknowns.

This is why I suggested / Requested. that you guys prepare a fully, detailed, explanation of how to save everything [with baby steps]. and copy paste this every time there’s a need to request a user to reset to default.

By now I’m good, I redone my keyboard and settings manually, [I had most of the keyboard SC saved in the 3D Connexion settings so could copy from there]

Another interim suggestion: to add a Macro for ExportPreference. that only open a dialogue saying something like “Legacy command, please use OptionExport to save your settings”

thanks a lot
Akash

Hi @dan
I Just found out that most of the GH plugins were not restored after the reset !
But fortunately they were saved in the backup file.

I copied everything back from Lib and User obj. directories … haven’t checked yet if all is there and ok…

But this need to be somehow mended please…
Like a Restore from Backup function perhaps …

Restore to factory can’t be a viable routine debug function if it takes so much manual effort to get everything back.

thanks a lot
Akash

I would like to address this and I will log some bugtrack items shortly. However, I wanted to come back to this issue because I still think we have a documentation problem here

…but before I do that, I wanted to ground-truth a couple things (which probably would have saved you quite a bit of time and I apologize that we didn’t address this faster).

First off, when you run the Reset command and select the Factory reset option

we always save a backup of your setting before the reset (I talked about this above and I’m repeating myself a little, so bear with me here) in a folder with the words backup YYYY-MM-DD-HH-MM-SS like this…

Now, as I sanity-check, I did the following in Rhino 8 for Mac:

  1. In Rhino 8 > Settings > Appearance, I set background color of my viewports to blue-ish.
  2. In Rhino 8 > Settings > Keyboard, I set the keyboard shortcut for Command+U to _Line.
  3. Started a new modeling window and tested my faux “customizations.” They work as expected.
  4. Ran the Reset command and to Factory Reset.
  5. Quit and Restarted Rhino and it’s back to factory defaults, as expected. Viewports are boringly not blue, and Command+U does nothing…all as expected.
  6. Ok, now imagine you want to get colors and keyboard shortcut back (a real stretch, I know :sweat_smile: )…so I Quit Rhino.
  7. In macOS Finder, I pressed Command+Shift+G to Go to Folder… and I entered ~/Library/Application Support/McNeel/Rhinoceros to open where Settings live (shown in the screenshot above).
  8. I selected the 8.0 folder and Trashed it (delete, drag to trash, whatever works for you).
  9. I selected the 8.0backup 2023-11-28-11-47-12 folder and renamed it to 8.0.
  10. Launched Rhino again. My viewports are blue-ish and Command+U runs the _Line command.

What I want to ask is: does this work for you? I hesitate to have you try it in case it doesn’t, but it really should.

Ok, let’s rewind again and go back to your idea:

It feels like what we need is a button (in the Reset dialog? somewhere else?) called Restore backup that essentially does what the above steps do. Are we on the same page? If so, I’ll get the ball rolling to make this happen in Rhino.

Ok, back to a harder problem: Documentation.

We are, as usual, behind on this and there’s too much out-dated and semi-useful or useless documentation that I can find…let’s take a look:

There are probably others. I’m working with others to see if we can clean this stuff up.

Finally, I just wanted to apologize, yet again, for all the hassle we caused here.

1 Like

Thanks @dan Dan

The renaming/replacing of the whole backup file make total sense …
I should have tried it then… kind of thought about it but not clearly enough to know that.

Yes a button that will do that will be great.
But even better would be to have a button that open a long list of everything, and let you choose either to Restore all, or select what you want to restore.
[because there may have actually been a good reason to do the restore to factory thing.]
So instead of restoring everything and then cleaning up the problem manually. If the problem is already known, perhaps unselecting that part will restore a repaired install …?
[but if this is complicated to setup, then just a full restore will be great .

I think it will be good for Mac users, [and easy to do] to bring back [temporally] the old Export Preference command that will open a note saying it is now called option export… or better and cleaner perhaps, is to have this [obsolete] command actually calling the option export. [with a note that it is obsolete].

Regarding importing stuff from 7… For Mac users, [unlike Window] there is not much that can be imported… most AFAIK, has to be done manually…?

thanks a lot
Akash