All preferences wiped out -- 8.0.23220.12306, 2023-08-08

Upon updating to the latest WIP, 8.0.23220.12306, 2023-08-08, all of my settings are gone.

Display modes, Aliases, shortcuts, etc. are no longer there.

I ExportPreferences prior to updates just in case something like this happens but in the new version, I can’t even ImportPreferences using a .plist file… It seems it will only accept .ini files for this now?

Is this expected behavior? This WIP version is a reset or something and all settings will need to be redone?

thanks for any info.


if so, is there any way I can revert to the previous version to get through the rest of the week and I’ll redo the settings this weekend?

hmm… so I changed the name of my preference backup from AUG9.plist to AUG9.ini and imported it and the stuff seems to import correctly.

my default template changed but that’s an easy enough fix… maybe some other stuff changed too that I haven’t found yet.

I think I’m good to go at this point but luckily I exported my prefs.

some other people who didn’t do that might be screwed with this update though so be prepared for some wtfs! :wink:

Hi Jeff -

No, that hasn’t happened here.

Glad to hear that you are sorted.
I guess we’ll see if this is more than an isolated case…
-wim

I lost my settings too, and no backup. Unless they could be dug out of TimeMachine…
Where does the setting file stored? [I’m guessing it would probably be In Application Support/Mcneel…?]

[Edit]
Is this the file that needs to be replaced? [Library/Preference]

thanks a lot
akash

no, same thing happened to my coworker… they’re not backed up.

(but they have nowhere near the amount of customization I have so not a huge deal for them I guess)

Hi Akash -

From Jeff’s comment, it sounds like renaming that to *.ini and importing that would work.
We are in the process of getting rid of plists and storing all settings in *.xml files as we do on Windows. I’m not sure that simply replacing that .plist file does anything anymore…
-wim

We didn’t do a good job communicating about this.

We’re hoping to obsolete the ~/Library/Preferences/com.mcneel.rhinoceros.8.plist in favor of storing everything in ~/Library/Application Support/McNeel/Rhinoceros/... xml settings files.

I don’t think we tested the migration path properly.

2 Likes

Thank for finding a way @jeff_hammond
I’ve found an old [older than yesterdays] .plist in TimeMachine, I copied and renamed it… But I see now that I actually don’t know how to import it ?

Into where do I import the .ini file?

thanks a lot
Akash

There’s a command called ExportPreferences and a command called ImportPreferences.

When you ExportPreferences, the file type it generates is a .plist

That’s the one I used to get all my settings back after changing it to a .ini

I really don’t think the .plist you’ve located is going to work but it’s worth trying.

So run the command ImportPreferences and see if it works.

Yes it doesn’t accept it… [tried renaming as preference but it doesn’t help]

I’ll see if i can overwriting the .xml.

[Edit].
So there’s no setting.xml before yesterday so it seems there’s no way to get back the lost settings.
It Would have been little effort to have given us an advance warning.
We could have had a chance to backup!
[ I used to save .plist in the past but didn’t think it applied to the WIP … and so forgot about it]

Akash

Hi Akash -

Theoretically (my settings weren’t reset so I can really test all parts of this), you should still be able to use an earlier WIP to export the options as a plist file and then do what Jeff did.

I’ve mentioned this several times in the past but I really recommend “installing” WIPs and SRs to the desktop and leaving at least one pervious version in place. On Mac it’s so easy to run different versions of the same major version as opposed to the way it is on Windows…
-wim

@Akash

Indeed, I think Jeff is right… You likely have the .plist after the new RhinoWIP obliterated the contents. However, if you have TimeMachine set up, perhaps you can rewind time and recover the contents pre-obliteration. The file is: /Users/~/Library/Preferences/com.mcneel.rhinoceros.8.plist - it’s worth checking if a version of it from, say, August 1st or thereabouts, is still there in TimeMachine. If it is, reset it and DON’T run the new RhinoWIP. If you can recover it, do this:

  1. Download the old RhinoWIP and install it on your Desktop. Rename it RhinoWIP-old.
  2. Launch RhinoWIP-old and ignore warnings about being obsolete and needing updating.
  3. Start a new modeling window. Run ExportPreferences and save the .plist to your Desktop.
  4. Quit RhinoWIP-old.
  5. The extension is incorrect for the new RhinoWIP, as Jeff points out. Let’s trick it like Jeff did. Change the extension to .ini (macOS will ask if you’re sure or not…you are).
  6. Launch the current RhinoWIP.
  7. Run ImportPreferences and find the (now) .ini file you saved to the Desktop. Choose all the options. It ought to work :crossed_fingers: (it did for me).

Note: the reason that step 5 is necessary is that the Finder window that ImportPreferences launches only accepts .ini files. However, it’s telling that it will actually import the contents of .plist (which is cool.) @JohnM Can you see a downside of just allowing this window to also accept .plist files? If not, that seems like an easy fix. Just in case, I logged this:

RH-76260 Allow ImportPreferences (Settings) to accept .plist files for backward compatibility

Akash, I hope you can recover your prefs. I’m sorry we didn’t fully consider the impact of this move on existing WIP users. That sucks.

Hi Dan
I’m trying your hack…
not sure I clearly understand about reseting the .plist. …?

  1. I got an Aug01 com.mcneel.rhinoceros.8.plist. from TM
  2. do I need to overwrite the existing one with it before installing the “old WIP”?

thanks a lot
Akash

Wonderful! A more careful reading of this topic shows you already said that. :grimacing: sorry.

I cannot be sure what you currently have in ~/Library/Preferences/com.mcneel.rhinoceros.8.plist, but let’s say you have a copy of the old “known-good”: (Aug01 com.mcneel.rhinoceros.8.plist. from TM) on your Desktop. In that case, what you need to do is use the RhinoWIP old to ImportPreferences on that plist. Once you’ve done that, you’ve effectively overwritten the contents of ~/Library/Preferences/com.mcneel.rhinoceros.8.plist. Quit and restart RhinoWIP-old for good measure, just to make sure things are as they were before we broke them. Next, in the RhinoWIP-old, run ExportPreferences and output those to the Desktop - doesn’t matter what you call them, just that they are written with the RhinoWIP-old. That’s the file you need to change the extension on.

Looks like the WIP_old does not accept the .plist

I tried renaming it in all sorts of ways…
com.mcneel.rhinoceros.8.plist (238.2 KB)

:grimacing: odd.

Try this.

  1. Quit all Rhinos and wait about a minute (macOS handles serialization of Preference files - or it did before).
  2. Launch Terminal and cd to the folder that contains the plist you just sent me. So, if it’s on the Desktop, run cd ~/Desktop.
  3. Next run defaults import com.mcneel.rhinoceros.8 /Users/~/Desktop/com.mcneel.rhinoceros.8.plist
  4. Launch RhinoWIP-old.

Does it appear to be your old prefs? I can see what appears to be a custom viewport background color when I do this with your preferences file provided.

If so, continue with steps 3-6 above.

Hi @dan
after typing as per your instructions:

it give me this in Terminal :

2023-08-11 01:35:12.205 defaults[63763:1315149]
Need a path to read from
akashlotan@Akashs-MacBook-Pro Desktop %

Put the com.mcneel.rhinoceros.8.plist that you attached above on your Desktop, then try this from Terminal:

defaults import com.mcneel.rhinoceros.8 /Users/akashlotan/Desktop/com.mcneel.rhinoceros.8.plist

Yes
it worked now, I can see my old colors

thanks a lot

2 Likes

Got the old pref. in the new WIP now.

Very Happy :slight_smile:

thanks so Much @dan

2 Likes