Levels And Cut Planes Not Working As Expected

In the Perspective View immediately below, the wall configuration shown cut is - as expected - the walls on Level 3 of this model. Note the settings in the Levels Panel:

Note that the Levels settings are the same as above for the detail on the layout below, but the model level being shown cut in the detail is not the Walls on Level 3. In fact it matches the cutplane display for the walls on Level 1 (shown at the bottom). It appears something’s wrong. I’ll upload the model.:

Hi @djhg,

Yes, it seems there is something wrong. I’ll need to model to check. I see, however, that in the first and last images, the “cut plane” is not enabled on the level manager, while in the center image it is. So the elevation on the cut plane will be different: in the first image, the cut plane will be at the level top, while in the second image, it will be at the cut plane elevation.

Regards,

Enric

Yes I have noticed that difference, but changing that doesnt improve things.

I’m working in Rhino 6 because of problems in Rhino 7, but opened this project in Rhino 7 also, just to see if there was any difference there. It doesn’t display the cut plane properly in the Level 3 detail window in Rhino 7 either . In fact, after some navigation between levels in the perspective viewport, Rhino became locked displaying only the cutplane for Level 1 there as well, and unresponsive to adjustments in the level panel.

I uploaded the model yesterday, by the way.

This is the most important issue for me to resolve to continue what I am doing. I can either roll back to an earlier version or find a work-around if there isn’t a way to fix this.

Hi @djhg,

I didn’t get this file. The one that you send seems different, or just a part of it. This is what I have if I show all layers and hidden objects:

Can you send it again? I’ll take a look ASAP.

Thanks,

Enric

Thanks. I just uploaded it.

I hope it reached you this time.

Hi @djhg,

We haven’t received the file yet. The last mail from you on visualarq@asuni.com account is from April 29th.

Regards,

Enric

I’ve been uploading to the mcneel upload site identifying it as an Asuni discussion.

Which email address did you sent the file to?

Enric

I entered the general asuni tech support email address on the mcneel upload page 1st. Second time I used mcneel (default) address and referred to your email address and linked to this thread in the message.

Hi @djhg,

Please, enter visualarq@asuni.com in the “Recipient e-mail address” field, or we won’t receive the file until someone at McNeel reads the message and send it to us. And as this is not strictly McNeel support, they may discard the message.

Enric

I’ve done so . The upload seems to happen impossibly slowly and each time I wonder if it’s really uploaded. I’m going to send you a box link also, but please let me know if the upload worked this time.

Hope you received the Dropbox link.
If we can get to the bottom of this it would be very helpful.

Yes! I got the file. I will take a look later.

Thanks,

Enric

Hi @djhg,

I’ve found the problem. When the “cut plane” icon is enabled in the Level Manager, VisualARQ looks for the top visible level on each building, and then, chooses to section the model using the lowest cut plane.

This is a bug because VisualARQ should set a different cut plane for each building, but first, we need to allow users to define the building footprint.

In your model, I think you don’t need the second building. You probably clicked on the “New building” button by mistake. Delete it, disable and reeable “Cut plane”, and it should work as expected.

Regards,

Enric

Thanks. This is good enough to keep me going. Ever since I accidentally created that building I have been stuck with it because I couldnt figure out how to delete it … please let me know how to do that.

Hi @djhg

Just select the building and press the X (delete) button:

Regards,

Enric