VisualARQ objects peaking through levels


I have recently switched to Rhino due to my new emlpoyer and I’m still trying to figure out how to work with BIM-features with Visual ARQ. I couldn’t find answer to my question with search or google. I’m currently working with a 3 storey building and for some reason all the lower floor elements are peaking through the floor on top view. For example when I’m working on the second floor I see all the first level walls, doors and space-objects even when I’m in the solid view mode. I propably have just some basic visibility settings set up wrong but I can’t figure out witch one and it makes working with the model really annoying. Everything looks fine in floor plans so the problem considers only model view.

Thanks for helping out.

Could you post a screenshot?

Hi @tuomas.ranta-aho, enable the Cut plane button on that level in order to see the plan view representation of that level:


Hmm. It works half way. I don’t see spaces anymore but walls and doors are still showing through.

Set the same Level settings you have now in Top view in Perspective view so you will get an idea of what the cut plane in that level is sectioning. Otherwise send us the model to so we can better understand what’s happening.

Hi @tuomas.ranta-aho,

We have checked the model and the issue is related to two objects (a curve and a surface) very far from the building model. If you do SelSrf and Zoom Selected maybe you will be able to find them. If you delete those objects, the visibility will work fine.
This issue is related to a Rhino limitation, actually it was happening also in other Rhino display modes like Shaded, and without any VisualARQ cut plane enabled.

Kind regards

1 Like