Layout layer visibility

unhandled

#1

I am trying to use the layout layer settings > layer visibility but the light bulb is not responding. The Icon changes from blue to yellow but the state doesn’t change neither in the layout viewport nor in the print preview. The commands Hide\Show Layers in Detail change the state of the visibility icon but do not hide or show the geometry as well. In order to hide \ show the geometry on the layer I need to right click the layer > Set properties > Off \ On in the layout layer settings which disables it globally. More importantly I need to be able to iterate through hundreds of layouts and change all the layer visibility per layout so I need to know is the layout layer visibility accessible in rhino common and where do I find it. A work around would be to use commands to set each layout as current and use show \ hide layers in detail but as I said they fail to change the layout layer visibility state. Thank you for your help!


#2

The per layout / detail layer on-off toggle only applies to the space that is currently active. So if you have a layout that has four details, and you want to turn off a layer in those four details, you will have to independently make each detail active, then turn off the layer for that detail, repeat for the next detail on that layout. If no detail is active and you turn off a layer using the per layout layer on-off toggle, only objects drawn on that layout are turned off, not the objects in the details on that layout.

Being able to select multiple details (not having them active, just selected) and being able to turn on and off layers in those details would be a welcome addition.

Sam


(Pascal Golay) #3

Hello- can you please post a simple example file that shows the problem? Note the control pays attention to whether a detail is active (hides/shows the layer in the detail) or no detail is active (Hides/shows the layer in the layout as a whole) .

-Pascal


#4

Thank you for your replies. I understand the function of Layout visibility now.

BR, Vangel.


#5

I cannot make it to mork in the Layout.
I am actually adding parts to my model after I had configured many layouts,
these parts now show in all the “old layouts” configured before adding the new stuff.

It is quite tideous to select all the different details in the layouts to deactivate these
Parts that should not be seen, it would be perfect to get layer control to work fpr all the
details in a layout in one go?!
Klaus
The below picture shows the layer “Leaders and Text” that was added foir the deck plan, which is another layout.


#6

Hello. I am still having troubles with Layouts/Layers in RhinoWIP. I need to make different details at one page:

Detail 1 - plan of the appartment
Detail 2 - plumbing
Detail 3 - electricity
Detail 4 - gas pipe

So I use Layout Layer visibility to show/hide what I need (for each detail separately). But after I change whatever LayerState I have (globally, maybe by accident), it always affects my detail layers visibility settings and everything is messed up. Is there a way how to set Layer visibility for each detail, lock that settings and keep it not affected by global settings?

This issue drives me crazy, but I might miss something important. I went through some other discussions at McNeel forum, video tutorials and still it’s not clear and intuitive. Could someone help me, please?


#7

Take a look at this post Wish: model layer visibility to be independent from layout layer visibility

Are you having the same issue?


#8

Yes. I already figured out the same:

  1. create whatever LayerState I need to work with
  2. create “ALL ON” LayerState
  3. create details > activate detail window > change Layout Layer visibility
  4. do not forget switch to “ALL ON” layer state before printing
  5. double-check everything and print

BUT

There’s strange issue I am dealing with:
A) activate detail with all layers on
B) apply any LayerState and deactivate detail
C) detail keeps its setting UNTIL…
D) activate the same detail again
E) apply the same LayerState again
F) close detail AND…
G) everything is messed up. It seems like there is some conflict with previous settings so it’s toggling layer visibility and combining previous settings, but I completely don’t understand how and why.

I really miss simple clear easy understandable solution for this issue. Which means - make it independent. I think there should be a possibility to lock detail layer visibility setting so it won’t be affected by anything once it’s set up. I am testing RhinoWIP and the problem still remains…