How to turn a layer on in layout

I’m having some trouble changing the visibility of layers in a layout. Maybe this is just an inherent limitation of rhino but I thought I’d ask anyway. I would like to turn on the visibility of certain layers in a viewport but I’m only able to turn off layer visibility. Am I missing something?

-David

it’s not possible (yet) but on the wish list for some time

Thanks Gijs

You want to turn on layers in a Detail view, right?
image

If you activate the Detail viewport (double click), this extra column of bulbs ‘Detail On’ will appear in the layer panel. It might be in the off somewhere, but it’s there.
Is this what you are looking for?

If no Detail is active, there’s an extra column ‘Layout On’. This is for objects placed directly on the Layout (not inside a Detail).

Might be off topic, but: be aware that the ‘main’ on/off-toggle (left column) will override the ‘local’ ones. That’s the reason why it is so easy to f up the content of a Detail view - by just turning layers on/off in the model space, which you normally do when working. There’s a lengthy debate about this. Hope there will be some other strategy regarding this in the near future. It’s needed. Really.

Hi Eugen, unless I’m missing something, you can only turn a layer off in a layout, you can’t turn it on.

I think I get what you mean: true, when the ‘master’ visibility (the normal or leftmost columns of lightbulbs) is turned off, you cannot toggle the Layout’s or Detail’s visibility. So, turn on the ‘master’ lightbulb, then you can toggle. This is indeed unsatisfactory, since the visibility of things in a Layout should ideally be decoupled from the model space. It’s possible to get the job done, but you need to be careful and do your extra clicks.
I revommend using Layer States for your Layouts/Details.

There’s a lengthy debate about the whole Layout topic here:

Youtrack entry:
https://mcneel.myjetbrains.com/youtrack/issue/RH-19685