Latest WIP error

Just updated Rhino 6 WIP. When I try to start it I get this error:

3 days ago I reported exactly the same error and the only answer I got was to reinstall WiP which didn’t help at all.

@brian
Might this be related to the idea you had in the Development meeting?

I uninstalled the WIP and dl’ed it from the website, reinstalled it and got the same error.

Nick

Same here.

what to do now ?

c.

Is there some short term plan for getting this working. Even though we aren’t supposed to be using the WIP for “real” work, I do have a couple of files that are only openable in version 6.
Nick

It looks like we may be failing to install one or more necessary parts of the Microsoft C++ Redistributable for Visual Studio 2015. Please install it from Microsoft and see if that helps.

It didn’t in my case.
My Win7 64bit Alienware didn’t “qualify” for that update.

I don’t understand what you mean by “didn’t qualify”. Can you send me a screen shot?

@brian The C++ worked here. Windows 7 Enterprise 64 bit SP1.
thanks!

@brian, thanks for the link. That fixed it and i`ve been able to open the WIP without reinstalling. (only error popping up was the missing cycles warning explained here)

c.

Hi Brian

When I say I din’t qualify I meant that update was “not aplicable” when I
tried to run an update from Microsoft page.
Running exe file I got the following message
Log file attached.
It may have something to do with the fact that this machine system was
trimmed and customized, but I know very little about it.

Regards
P

@clement, see the answer in the referenced thread - in short: reinstall with the installer that you used for the update, or get a newer installer/update.

/Nathan

@nathanletwory, thanks it works now using CPU after reinstall, i do not get the plugin warning anymore. Using OpenCL (Radeon Tahiti) causes an instant crash though.

c.

@clement, yes, I am aware of OpenCL support falling behind. I still have to give that some extra love, but it isn’t yet on the top of my list.

I’m sorry for the inconvenience.

/Nathan

1 Like

@Piotr
What is the detail in the linked “log file”?
Perhaps save the log file and upload it as an attachment to a reply.

John
I couldn’t attach log file so I converted it to txt. hope it helps.
pdd_vcredist_amd64_20160301072014.txt (14.8 KB)

Hmmm…
That log doesn’t follow the same “rules” as MSI error logs.

Is there any chance the downloaded file has a compatibility assigned to it for an earlier failed install attempt?

Check the Properties of the exe file under Compatibility. It may have been tagged by the Microsoft PCA (Program compatibility assistant).
If it is, clear the compatibility requirement and try it again.

John
Clearly it did not.

It appears this may be a problem Microsoft is working on but has not released a fix for humans yet. I found this link:
https://social.msdn.microsoft.com/Forums/vstudio/en-US/64baed8c-b00c-40d5-b19a-99b26a11516e/visual-c-redistributable-for-visual-studio-2015-rc-fails-on-windows-server-2012?forum=vssetup