WIP Install Problem


#1

I tried a number of times to install the WIP. It seems to install properly, but when I try to run RhinoWIP I get a message saying “api-ms-win-crt-runtime-l1-1-0.dll” is missing:

I am installing alongside a stand-alone version of Rhino5, am using Windows7 and have tried both standard Install and Redistributable Install and get the same problem, if that helps.

Any ideas? Could you perhaps supply the dll and let me know where to put it?


(Brian Gillespie) #2

Hi, That’s weird…

api-ms-win-crt-runtime-l1-1-0.dll is supposed to come with the Microsoft Visual C++ 2015 runtimes.

Please try this:

  1. Uninstall Microsoft Visual C++ 2015 Redistributable (x64) from control panel
  2. Install Rhino

Now does Rhino start?


#3

Thanks for the quick reply, but it didn’t work. It re-downloaded the 2015C++ Runtime but couldn’t install it

I also tried to install the 2015 package manually from the “Redistributable” install method but it wouldn’t install. I also downloaded the redistributable from Microsoft and it wouldn’t install!
Hangs at the very end when it is trying to install “Windows7_MSU_x64”.

Not sure what you can do to help if MS’s own redistributable won’t install for me…


(Brian Gillespie) #4

I can’t tell from your description if you first uninstalled the runtime - did you?

Also, be sure to restart your computer and apply any pending Windows Updates - sometimes Windows Update can make a mess of installation processes.


#5

Yes I first UNinstalled the runtime.

This morning I managed to get it working. After a night with everything UNinstalled and turned off it seemed to behave better this morning. Installed the runtime from the rhino-downloaded Redistribution (tried Microsoft’s runtime, which installed also, but was a few minor versions numbers older than the rhino version so rhino still wanted to install its own version).

So SUCCESS!

I had to turn off OpenGL Hardware Acceleration so that the screen rendered properly, otherwise all viewports were completely black - don’t have this problem with Rhino5 which renders fine with Acceleration on! (onboard Intel HD 4000 graphics)

Many thanks for your help.


(Brian Gillespie) #6

I think @jeff is out of the office for the next week or so, but it seems like he’ll need to look into this.

I’m glad you got Rhino installed and working.


#7

I’ve just installed the update to WIP. You seem to have removed the option to disable Hardware Acceleration for OpenGL - a backwards step in my case! I still have the problem of completely black viewports, but now I cannot use WIP at all, because I can’t turn off OpenGL Hardware Acceleration.

Any idea how I might either a) be able to fix Rhino6 so it renders properly, or b) disable Hardware Acceleration.
Obviously I can start it in Safe Mode (and the screen does indeed render properly) but it’s not a great solution…


(Steve Baer) #9

Hi Paul,
Hopefully we will be able to fix the black viewport bug in the near future. We are starting to pinpoint where the error is occurring on a couple user’s computers and are still in the process of figuring out the cause.

In the meantime, you can still disable hardware acceleration. We moved the control to the advanced settings page since we were finding several users turning HW acceleration off when they didn’t need to. HW acceleration off is what I would consider a last resort to get Rhino to work. In your case, you are at that last resort case and need to turn HW acceleration off to keep working in the WIP.

Open the Options dialog and click on the advanced entry on the left hand tree control. Type OpenGL in the filter at the top to filter down to just the OpenGL settings. Set the
Rhino.Options.OpenGL.UseHardwareDriver
to False and restart Rhino.


#10

Steve,

That trick worked great. I have disabled the Hardware Acceleration and have got my viewports back.

It doesn’t display the font on the viewport axes properly:


as the “X”, “Y” and “Z” (and possibly the “GPU Disabled” message) is shown as a grey block rather than as individually recognisable fonts.

I can obviously live with it, but thought it might help you debug what is going on. (It doesn’t occur when I start the WIP in safe-mode).

Paul.


(Steve Baer) #11

Safe-mode doesn’t actually use OpenGL which is why the display is different. Please continue to try enabling HW acceleration with new WIPs. We don’t want to mask the bug with the current approach.


#12

I experienced the same problem with the text not displaying on a Win7 machine. I downloaded and installed the latest Win7 “Recommended” updates with no improvement but after installing the “Optional” updates, the problem was fixed.


#13

Thanks for sharing your experience and suggestion Gary, but I have my laptop set to auto install Optional updates.