Issue Importing IFC with VisualARQ

Hi I’m having trouble importing an IFC file into Rhino using VisualARQ. I downloaded what I believe to be version 2 of VisualARQ as another thread recommended but I’m still having issues. I know the IFC file originated from ArchiCAD if that has anything to do with it and I included a link to a video showing how I tried to import it.

Justin

Hi @justinitehrani,

I cannot see the video. I don’t know if it is a problem on my browser or in the video. Please, could you send it to visualarq@asuni.com?

In order to open an IFC file using VisualARQ, make sure that VisualARQ is loaded (run any VisualARQ command before opening the IFC file).

Regards,

Enric

Enric,

I gave what you recommended a try and it still came up with the same issue.
I uploaded a video to youtube this time. https://youtu.be/TOh_1CYPGNE

Justin

Hi,

Now I see the problem: VisualARQ is crashing when you try to import this IFC file. Can you send me the IFC file to visualarq@asuni.com? Is that is not possible, please, send me the file “RhinoCrashDump.DMP” (the DMP file, not the 3DM) that will appear in the desktop. Take into account that the DMP file will be automatically deleted after closing the crash dialog, so make a copy.

Regards,

Enric

Sent

Hi Enric,

I have the same problem while import ifc file into Rhino. After a few minutes, Rhino just crashed. The ifc file only 11mb, so I assume it’s not because the file size.

Could you please help me with a solution?

Thanks.

@hurriarc we have compiled a new release of VisualARQ 2 (2.0.18) that fixes this error. You can dowload in this link: https://visualarq.s3.amazonaws.com/download/visualarq-2.0.18.11993-rhino5-x64-setup-snapshot.msi
Regards,

1 Like

Hi Francesc,

side question, is there any ETA of VA for v6?

@D-W We are currently working on the VisualARQ version for Rhino 6, but we can’t say yet when it will be released. Take a look at this post for more details: Test VisualARQ in Rhino V6

1 Like

Hello,

I have the same Problem as [Justinitehrani]. If I try to import a dwg with Rhino, it works. But if it’s an IFC data, the Software doesn’t react. Could you please help me?

Loïc

Hello Loïc,

Did you get any warning/error message? Was VisualARQ loaded before you tried to import?
Could you try again running vaInit before importing the ifc file.

If nothing works please send to visualarq@asuni.com the ifc model and information about the VisualARQ version you are using so we can take a look at the issue.

Regards

For the one which we’d like to Import, the programm at least reacted after I gave “valnit” but stay hanging during the import, I guess it’s because the file is too heavy (121 MB).

For another file, I get an error message (doens’t comply with IFC2x3 Format specification) and then the program crashed.

And yes , VisualARQ was loaded before I started the import

Hi Loïc,

Could you send the second ifc file you mentioned (the one that make the program crash) to visualarq@asuni.com ?

Thank you

Hi, I have a recurring issue with importing IFC’s. Quite often objects are not trimmed it appears:
image

Is this related to Rhino’s mesh boolean and mesh trimming bugs?

While in Solibri:

I’ll send you the IFC @RamonC

@Holo, this issue has been fixed in VisualARQ 2.8.3: VisualARQ 2 - Version 2.8.3 released

1 Like

Hi Francesc - I too am having issues with IFC files…many issues.

These are received from a variety of companies, presumably also produced from different programs. Here are just some of the problems I’ve been having:

  • IFCs hang at the point of “building geometry”
  • Hangs/crashes whilst saving the file as IFC
  • Hangs/crashes when trying to copy to clipboard
  • Some objects (eg slabs) disappear when copying into another open Rhino session, whilst others are fine.
  • Objects lose their properties on import

There are others but these are the most frustrating ones. The whole process of trying to do even simple things with IFC files is very difficult. Any advice?

Hi @Ben_B, we may require the IFC file (or the 3dm file you are trying to export to IFC) to see if we can reproduce all these issues, analyze what’s happening and fix anything we can do on our end. Please send the files to visualarq@asuni.com

Thank you Francesc, I have emailed you.

Hi @fsalla

I still have trouble importing IFC’s with correct holes in them. And this really needs to be solved so it can be used reliably. And these holes you see missing here are rectangular holes in rectangular walls, so it shouldn’t be too difficult for Rhino’s boolean tools to fix.

Solibri:

Rhino: