Help.... Docked panels always messed up

Hi everybody,
Rhino is driving me nuts. Since this afternoon every time I open Rhino (version 7.3) I have to rearrange all docked panels.

See the image below. Thats how Rhino opens every time. Then I put the Properties, etc panel under the Layers panel, and I switch sides of the ObjectSnap and Selection filter panels, and I want the commad line om the Left and Bongo timeline on the Right.

If I do all the arrangement and I close and reopen Rhino it’s again like this:

I tried running Rhino as administrator… doesn’t help.
Please, what can I do? I can’t work like this.

Thanks Tobias

I’m running an in-house development build which will become V7 SR5 and not seeing this problem.

I rearranged my panels so I have two docking containers, one below the other.
I did this with a single instance of V7 running.
I closed Rhino and reopened it.
It worked as expected:

Hi John, up to this afternoon it worked here too.

If you can come up with the circumstances required to repeat the problem, and if those instructions work for one of use here, then it can get added to the defect list.
Without that, there is nothing to be done.

How long has it been since you rebooted Windows?

Hi John, I tried to investigate a little. I know which file I opened and after it the problem started. I backed up my laptop and tried the same file there but on my laptop everything works just fine.

I also noticed that every time I restart Rhino the commandline / timeline together with the osnap / selection filter panel swaps sides. I mage a video to demonstrate it. Maybe it can help:

I know this problems are hard to tackle since you cannot repeat it, but maybe you have another idea I can try.

If not than I have to completely remove Rhino7 and reinstall it, and hope that it will fix it.
What would I have to delete to completely uninstall Rhino 7?

Thanks, Tobias

Ok, looks like I found the problem.

Today I cleaned my pc from everything Rhino 7 (registry, appdata, etc). Reinstalled Rhino 7 …problem still there. But then I had a look at the plugins. Only non stansard plugins were bongo and 2 denoisers.
I disabled the Intel and NVIDIA denoiser, restarted Rhino and everything was back to normal.

Then for a test I enabled the 2 denoisers again but Rhino is still starting normal. Hmm… so there is still a mystery somewhere. Maybe it’ll come back but the I know where to look.
The same of course for everyone encountering this problem. Check plugins first.

Anyway thanks John for your input.

greetins, Tobias

Very interesting…
@JohnM
@will
Any thoughts?

I have the Nvidia denoiser installed and running.
I’ve disabled my Intel GPU in Device Manager so there’s no reason for that denoiser on my system.
I have Bongo running too and no problem here.

Ok, I cheerd to early. I am back to the same shit. Turning of plugins doesn’t help.
What a fuckup…

Maybe you can try locking the Toolbars after you made your arrangement and see if that makes any difference.

Hi Gijs, I tried locking of the panels, and unlocking, open Rhino as administrator, etc… multiple times.
There must be something on my computer causing this. On my laptop things are working just fine. I also reinstalled my display driver… to no avail

I am quite lost. Don’t know what to try again. There’s no way I can work like this.

Just to be sure: have you got latest drivers? Is this hybrid system? Do you sometimes have multiple monitors attached? Did you try with a different monitor/ display port/ display port cable.

One other thing I can think of is to make sure all toolbars are from one rui by copying your Vray/Bongo toolbars to your default and then closing thoses rui’s (or at least turn off their toolbars) and make sure to save it under a custom rui name where you are sure to have all write access to.

I have the same issue since basically I can remember in Rhino, but have given up trying to fix it. I am on the latest Rhino 6 and it has been like that at least since the beginning of V6. Curiously it’s not ALL panels. But moving the layers panel and properties panel to different locations it opens them in the default position again EVERY time.

This sounds like something Rhino should be doing automatically. Shouldn’t it have one rui file and update that whenever I move a toolbar? I don’t understand why this is so difficult when I have not come across this issue in literally any other software and here it seems like a problem that people report regularly over the last few years.

Hoi Gijs, it’s really amazing how you can tackle a problem.
I am a little careful now to call it a solution, but the problem might indeed be related to my monitor setup. I have 2 monitors on my desk and the desktop is extended to a tv. So 3 monitors. If I disconnect the tv things seem to work (for now)

That being said, I don’t think this should affect Rhino in any way. So if this is the cause of the problem its clearly a bug. No other software on my computer suffers from my monitor setup.

All right, I keep on testing and keep you updated.
But absolutely brilliant thinking from your side!!!

greets Tobias

1 Like

Ah good to hear you have at least found the source of your problem. I don’t have multiple monitors so hopefully others that do can chime in.

@seltzdesign I’m not sure if this is a solution to that, it was merely a suggestion to try out.