Rhino 6 keeps switching position of toolbars back and forth with each startup

Ok, so the computer at my workplace just got upgraded from Windows 7 to Windows 10 (clean install, version 2004), I backed up all my settings before and imported them. I’m using Rhino 6.29.20238.11501. Now I’m facing this very strange issue:

  1. I set up the positions and size of my toolbars how I want (and had them set up in this exact way before).
  2. I close Rhino
  3. I open Rhino, now the toolbars both on top, bottom and left side of the viewport switch positions to their mirror image (the rightmost becomes leftmost, middle one stays in middle…), plus the vertical toolbars on the left get all mangled.
  4. I close Rhino
  5. I open Rhino and the positions switch back. Left toolbar remains mangled.
  6. I can repeat steps 2 to 5 indefinitely with absolute regularity, except the left toolbar looks slightly differently each time, sometimes revealing more buttons, sometimes hiding them
  • If at any step I change the position of the toolbar, it again switches position at next Rhino startup.
  • It doesn’t matter, whether Lock Docked Windows is checked or not.
  • The only non-standard plugin I’m running is V-Ray for Rhino. I tried disabling it completely, but the issue remains. (Is there any other of the default plugins that could cause this?)
  • I tried resetting the toolbars to default, I tried resetting all the settings to default (I kept a backup copy of the default settings files found in AppData/Roaming), but as soon as I add a toolbar and place it horizontally next to another one, this issue reappears.

This is what I’m trying to achieve (this very setup used to work flawlessly before the OS reinstall):

This is what I get after the first restart of Rhino (and subsequently every odd restart):

This is what I get after the second restart of Rhino (and subsequently every even restart):

Is there any solution? Or is this just broken in Windows 10?

I will do some testing when I get home where I have old Rhino 5 running on Windows 10. I’m pretty sure I have similar toolbar setup and it works there.

Yep, confirmed, my Rhino 5 running on Windows 10 (version 2004 as well) has no problem whatsoever with this:

No toolbar moves even a pixel.

Hi Simon - there are a couple of things to try -

  1. Open Rhino and ‘restore’, i.e. not maximized, the main Rhino window.
  2. Stretch the window out to as maximized as you can.
  3. Arrange the toolbars.
  4. Maximize Rhino.
  5. Close and re-open…
    Any better?

-Pascal

Hi Pascal, thanks for your suggestion. I tried following your instructions, then I tried all sorts of combinations like closing Rhino while the window is restored, making the window even smaller, undocking and docking the toolbars after restart, keeping the toolbars locked or unlocked, running Rhino as administrator etc. but to no avail, the horizontal toolbars keep switching sides.

The only thing I managed to do was to find a layout of the side toolbars that was stable. The vertical toolbars didn’t change size and didn’t even switch positions. So it was alternating between these two states, this:


and this:

At least until I tried to fiddle with the toolbars again, thinking it was because of the first column containing only one toolbar. Well, that wasn’t it and now I can’t recreate that state or any other stable state no matter what (I even used the screenshot as a guide to try getting it as precise as possible), so I don’t know what miracle that was.

Well, I have never had any real success docking multiple horizontal toolbars next to each other, in the end I just created one long custom toolbar by copying the buttons I need.

That could solve the left toolbar but cannot be used for the others - at the top is a combination of a toolbar group, regular custom toolbar and a filter panel and on the bottom a combination of Osnap control and VRay toolbar. You can’t copy buttons between those.

Hi Simon - this does not solve the problem - but it may hide it well enough (meantime I’ll see if I can reproduce what you show): Put the filters up next to the command line. Is that stable?

Your configuration seems fine here… do you have more than one RUI file open (Options > Toolbars page) and do the toolbars you are docking come from more than one RUI file?

-Pascal

Hi Pascal,
no, the filters next to the command line also switch places.

I do have two RUI files when the VRay plugin is turned on. If I disable it, I only see one ‘default’ RUI (but the toolbars are still acting up).

I also tried putting filters next to the tab group on colleague’s computer (Rhino 6 + Windows 10) and it works fine there. So there’s clearly something wrong with my setup. I don’t know if importing my old options initially could break something?

Edit: Funnily enough, I noticed that my left toolbars have just now, after changing positions randomly with each startup numerous times, managed to find a stable state completely on their own:

Other thing I noticed is that if I run a second instance of Rhino, it opens with the same toolbar setup as the one currently open. It’s only when I close one of the instances and open one again, do the toolbars move. So it’s clear the problem is happening as Rhino closes and saves the toolbar positions (but this was probably obvious before).

Hi Simon - with no Rhino running, can you locate the settings files here:
C:\Users\YOUR_USER_NAME\AppData\Roaming\McNeel\Rhinoceros\6.0\settings
and rename them, then start Rhino and see if things stick?

-Pascal

Hi Pascal, sadly no. I renamed it, Rhino created new files upon start, but it keeps doing the same thing.

Hi Simon - I am running low on ideas - what is your monitor setup? What resolution(s). Can you please run SystemInfo in Rhino and copy/paste the results?

-Pascal

Hi,
I have two 1920x1200 monitors.

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Commercial, build 2020-08-25
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: [REDACTED]

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 960 (NVidia) Memory: 4GB, Driver date: 9-30-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.71

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  
  Anti-alias mode: 8x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: Height
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 9-30-2020
  Driver Version: 27.21.14.5671
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 4 GB

Rhino plugins
  C:\Program Files\Rhino 6\Plug-ins\Commands.rhp	"Commands"	6.29.20238.11501
  C:\Program Files\Rhino 6\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp	"Rhino Bonus Tools"	
  C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp	"Rhino Render"	
  C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	6.29.20238.11501
  C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	6.29.20238.11501
  C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	6.29.20238.11501
  C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp	"V-Ray for Rhino"	
  C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Program Files\Rhino 6\Plug-ins\Calc.rhp	"Calc"	
  C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp	"Named Position"	

I also updated the GPU driver (since I noticed it was outdated when running SystemInfo for the first time) but that didn’t solve it.

Hi Simon - as a test, can you disconnect one monitor and see if Rhino behaves any better?

-Pascal

I have roughly the same setup - a 980Ti and dual 1920 x 1200 monitors. It’s pretty stable. But I only have the filter panel, the osnap checkbox panel and one small toolbar docked next to the command line. No other horizontal (or for that matter vertical) docked stuff.

Ok, will try on Monday when I get to work, although I have a suspicion it will not work either. The colleague on whose computer it works fine also has a two monitor setup.

(These different timezones really don’t do us any favor here.)

Hi Pascal,
just arrived at work and tried disconnecting the secondary monitor. Now we were finally getting somewhere: with the monitor unplugged, the toolbars stayed in their positions. But as soon as I reconnected the monitor, the toolbars switched positions with the next startup. No matter which monitor I moved the Rhino window to.

Now comes the incredible part. Now keep in mind that these two monitors are identical, it’s the same Dell model. Desperate, I tried setting the other monitor as primary and now the toolbars stayed in place. I tried switching the monitor positions (virtually in Windows) and it still worked. But once I set the original monitor as primary again, it stopped working. Now, the original primary monitor was connected via a DVI-D cable and the secondary monitor via DisplayPort. So I switched the cables. Now if you think you know where this is going, you’d be wrong: the Rhino toolbars started working and it now does not matter which monitor I set as primary!

But I did more testing, trying every possible combination and I found one that does break it.
In Windows settings, move the monitor connected via DVI-D to the right and set it as primary. This is the same combination my original setup used. So after all, it doesn’t matter, which of the two monitors is physically which, it boils down to a specific combination of cables, virtual location of the monitors and which monitor is set as primary/secondary. Every other combination works fine.

So, solved, I guess? This is the weirdest bug ever.

Hi Simon-

I think I feel better now. I think.

Thanks for the extensive testing - I have no idea at all what happened here, but I will point the developer to this conversation in case he has some insight, or needs to be entertained…

@SimonR - could you please send us the exact model of monitor, and the computer, as well as Rhino’s SystemInfo output? Thanks.

RH-61089 Toolbars: docked toolbars switch positions at startup

-Pascal

Hi Pascal,
the monitors are DELL U2412M.
Computer is Intel Core i7-5820K 3.30GHz, 16GB RAM, GeForce GTX 960.

I sent you full system info exported from DxDiag as well as Rhino’s SystemInfo output via a private message.

Anyway, thanks for the patience and pointing me in the right direction regarding the monitors, I would’ve never expected that. I’ve encountered some weird bugs with computers before but this one has to take the cake.

@SimonR - have you tried this with the V7 beta? If not and you find the time to do so, could you try and report back?


-Pascal