UI Settings Not Being Saved - Toolbars

I’ve modified my workspace - relocated panels, setup toolbars, etc. however, the UI doesn’t save all of these changes - toolbars are fine, but the properties and box edit tool panels keep moving after re-opening Rhino. I had a similar issue with the Rhino 6 trial.

Edit:
Now its both the toolbars and the tool panels - the tool bars were set to a double column on the left and now they are all grouped into 3 double columns. This just started happening after I tried running as an Administrator. In addition, now Rhino opens a different icon in the taskbar from the pinned shortcut.

Also, this is a new computer build from just a few days ago - my previous building and installation of Windows had no issues with the Rhino 7 UI, however, that previous buildi/installation of Windows had issues with the Rhino 6 UI. I

Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09491, Git hash:master @ 350b20978b4fcd75493212fbd3c4248983612f86)
License type: Commercial, build 2020-12-08
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3080 (NVidia) Memory: 10GB, Driver date: 12-11-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 460.89
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-11-2020
Driver Version: 27.21.14.6089
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 10 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

the standard fix for this is to run rhino as admin (right click on the icon and choose run as admin)

rearrange rhino as you prefer then choose file>exit then relaunch rhino normally.

any luck?

I’ve tried this and so far it’s working.

  • Yinka Oyesiku

woot! great- let us know if it misbehaves again.

Unfortunately, the issue is still not resolved. Just happen again this afternoon, despite working fine 15 minutes before.

  • Yinka Oyesiku

Hello - one thing to try, if you have not, is to block, disable the VRay plug-in in Options > PlugIns page then close and restart Rhino, arrange things as you like, and carry on for a bit to see if it continues to behave without VRay. That seems unlikely to be the thing that fixes it but it will be just as well to eliminate that first.

-Pascal