Geometry movement delay when holding shift down

When I press shift for constraint, my geometry lags behind the cursor and catches up eventually! I`ve been working in Rhino for many years and this is new to me. Just got a new pc, all the best, GeForce1080 etc. Anyone with same experience or fix…

First thing to do I’d say is make sure all your drivers (GPU) are up to date.


thanks they are the latest…

What Rhino version?
Can you post a screenshot of the openGL settings?


Indeed up to date drivers.
Did you get Rhino up to date with the latest SR?

That would be my last guess, maybe someone else can chime in to help out.


Thanks Willem!

Hi Nicolay - did you get this sorted out?


No, but both Rhino 5 32bit and Rhino 6 WIP does not have this issue. I run a small office and all the various pc’s have the same issue with the 64bit. It feel like holding shift down runs the movement somewhere really weak…then again Im not really a geek:) Whish I could use 6WIP but I use Vray all the time so…not for some time I guess. Strange I can’t find anybody with the same problem.
Thanks for the follow up!

Hi Nico - the other thing to eiliminate is plug-ins - what plugins are you running, if any, that are not default Rhino ones - any new ones that correspond with the new behavior?


I am having exactly the same problem and it’s getting so annoying… Could someone from McNeel resolve that ASAP, please? The only plugin I am using is Grasshopper… Also, my mouse is Logitech MxMaster 2 … should be fine. Maybe if it’s graphic card issue, how can I fix it?

I might still try updating your drivers to see if it helps, we’re up to 390.77 now…

Nothing more is going to be done to Rhino V5, so the “resolve the issue” is going to need to happen on your end more or less…

Thanks, I will try. My system told me the driver is up to date. As You noticed me, I am updating system manually bcs obviously there’s newer version of nVidia driver available…

No difference.

I can still move / copy objects and it’s fast and smooth. But when I hold any key (shift, tab, ctrl…) while copying or moving object, the object movement slows down while mouse is moving “normally”. Any ideas?

Did anyone ever resolve this? Suffering the same thing with Rhino 5 64bit.

Just found the same exact behavior.
(Rhino 6.11.18323.19181 - GPU drivers updated)
Tesselation on/off no change, changing GPU driver setting didn’t help.

I’ve seen this many time in past, but I’ve never been able to isolate it.

As ortho is on, if I press shift to temporary disable it, the delay happens.
(the same happens if I hold shift to temporary enable ortho)

I wanted to record it, and by doing it I’ve discovered an additional thing.
The sequence here is:
-I start the polyline;
-start the .gif recordering;
-now the “in front” program window is the .gif recorder not rhino > everything smooth as it should be;
-I click and make the second point of the polyline > rhino become the “active window” > high delay in viewport.
(Ortho is on, it never lag if i don’t hold shift key)
(I’ve used ScreenToGif)

So… it’s like Rhino is “intercepting” the shift key in a wrong way, making everything delayed.

Hello - are you running any plug-ins that do not ship with Rhino? Can you please run SystemInfo in Rhino and paste the results here?



In SR10, running a Quadro P2000, I have no delay at all.
In SR12 (in-house build) on an Intel Iris 540, I have a barely noticeable delay.
Certainly nothing like in your video.

I just turn off every automatic startup with msconfig, disconnected every unneded usb hardware, rebooted the system.

The problem happens also by just drawing a polyline while rapidly clicking new points and moving the mouse… slowly the viewport become “behind” the actual cursor.
I tried to record it to .gif but with that software active the delay doesn’t happen at all!
(So no shift key involved here, just rapid clicking for a polyline/copying object etc…)

Anyway, here it is:

Rhino 6 SR11 2018-11-19 (Rhino 6, 6.11.18323.19181, Git hash:master @ 0200b43a48c2d93d905df89b7bd77bf8678fdd21)
Licence type: Commerciale, build 2018-11-19
License details: Cloud Zoo. In use by: Riccardo Majewski ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: SHARKOON-AMD

Radeon RX 580 Series (OpenGL ver:4.5.13541 Compatibility Profile Context 24.20.13019.1008)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.50
Driver Date: 9-25-2018
Driver Version: 24.20.13019.1008
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.11.18323.19181
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.11.18323.19181
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.11.18323.19181
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.11.18323.19181
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - what happens if you disable VRay in Options> Plug-ins and then restart Rhino?


1 Like