Slow dragging with shift key pressed

Hi,

when moving geometry in Rhino 6 while holding the shift key, to either constrain or unconstrain the direction, moving becomes extremely slow. The geometry is lagging the mouse pointer substantially. The lag increases with the amount of geometry present in the file, but can also be demonstrated in empty files. Please see video in zip fileVideos.zip (5.1 MB)
. With large files the lag is so strong, that we sometimes have to kill Rhino.

A similar lag exists in GH when reconnecting wires with Ctrl+Shift pressed. The lag increases with bigger GH definitions. Please see video in zip file.

The problem exists on all machines in our office (laptop and desktop computers), with different graphics cards and different models.

Please see the _SystemInfo information for my personal laptop below.

Best
S

Windows 7 SP1 (Physical RAM: 16Gb)
Machine name: ROK-0001

Hybrid graphics system.
Primary display: Intel® HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 3-23-2016 (M-D-Y).
Primary OpenGL: NVIDIA Quadro K2100M (NVidia) Memory: 2GB, Driver date: 1-23-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 390.77

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-23-2018
Driver Version: 23.21.13.9077
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”

I think the standard answer in your situation is:

  1. Update your graphics drivers.
  2. Make the Nvidia card the primary.
    See how it works and post again if it’s not much better.

Just to clarify.

Everything is up to date. Rhino is only using the NVIDIA card.

I see the same behavior on all my students computers (at least the ones i looked at) as well as on the computer clusters of the school I am teaching at. I am very surprised there are no other posts about this on the forum.

Hello - please see if disabling VRay in Options > Plug-ins page and then restarting Rhino makes any difference.

-Pascal

Hi Pascal,

I missed to switch Vray off before.

It reduces the problem substantially. In small files there is no lag. In a file with 25000 lines, I can notice a slight lag, but it is a lot better than with Vray enabled. Same goes for GH.

Btw. an unrelated problem you might want to forward to Chaosgroup. When I disable the Vray plugin, Grasshopper crashes upon start, when loading the Vray gha. I submitted a bug report referencing this thread.

Thanks - S

Not sure what you mean.

Here’s the link to Nvidia’s driver download page:
https://www.nvidia.com/download/find.aspx

and here’s what it shows for your configuration:

also, I think @John_Brock has a link for the latest Intel drivers. 2016 seems pretty old even for Intel.

Here’s a link to drivers for the 4600 from 19 March 2019:

If anyone is curios, use this link to get to Intel’s drivers. You need to know the development code name for the display chip, then drill down inside the description of each driver to find your card model.

@John_Brock, @wim
Thanks for the tips. Sadly it didn’t change. Since this is caused by Vray, I can switch off the Vray plugin for large models, when it is bugging me.

1 Like