Move command slower in V6

performance
unhandled
move

#1

Hey all,
I’ve just noticed, there is an “inconvenience” which is related to moving objects. The speed of the move command is quite “laggy” or slow in V6. Much slower than in V5. I am experiencing this only within this command (so far). Any ideas what could cause it?


(John Brock) #2

Do you have any extra plug-ins installed?
If so, does this lag go away of your temporarily disable them and restart Rhino?
Options > Plugins > Plugins that do not ship with Rhino


#3

Well, unload plugins doesn’t help. But the situation goes better when I uncheck GPU tessalation (I have quite old laptop with NVS 4200 graphic card). Still not perfect, but better. I remember I had several performance issues with V6 in past. Could it be caused because of the bigger GPU utilization of V6 than V5?


(John Brock) #4

Absolutely.
V6 requires a higher OpenGL specification too.


(Steve Baer) #5

This only happens with the Move command? I doubt that this is solely due to GPU tessellation being enabled and that there is something else going on. Can you post the results of running the “SystemInformation” command here? Maybe some of this information will help us figure out what is going on.


#6

Displacement property slows down the Move command unless the initial mesh quality is set to low (or Displacement is turned off).


#7

I’ve noticed this other places as well. Selecting objects is definitely slower in V6. Plus it tends to bog down after prolonged orbiting and panning in the perspective view. Mostly in shaded mode or rendered mode.


#8

Just out of curiosity - you can try the same command in fullscreen. A good percentage of slowdowns is actually caused by UI drawing code. Especially numeric fields update way too fast.


#9

hmmm, good point. It seems this problem appears within commands related to “moving” objects (copy, move, mirror etc.) But in general, V6 seems to be much more slower in operating with these command than V5. (in my case). Maybe there is some settings which could help to increase the performance…?

Here is my system info:

Rhino 6 SR7 2018-7-2 (Rhino 6, 6.7.18183.14071, Git hash:master @ 9cbbaac139cbf6c08c2e0e73e0a1f88fd0021a4a)
Licence type: Educational, build 2018-07-02
License details: Cloud Zoo. In use by: Petr Tůma ()

Windows 7 SP1 (Physical RAM: 7.9Gb)
Machine name: PETR-THINK

NVS 4200M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.74)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-4-2018
Driver Version: 23.21.13.9174
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.7.18183.14071
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.7.18183.14071
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.7.18183.14071
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.7.18183.14071
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”


#10

My mesh quality is set to low


(Steve Baer) #11

Here’s a few things to try…
Run PlugInManager and disable Snapshots, 3Dconnexion 3D Mouse, and Displacement. Then restart Rhino and test speeds. I don’t think these plug-ins are causing problems, but it is good to eliminate these as possible causes. If the display seems the same speed go ahead and re-enable these plug-ins

Close the properties panels and test display speed again.

That is all I can think of at the moment to try.


#13

Plugins disabled but without any response. Weird, V6 should be faster even on my older laptop huh?


(Steve Baer) #14

Does the model appear faster in V6 when you run TestMaxSpeed compared to V5? Note: you need to run TestMaxSpeed a few times and take an average to do a decent comparison.


#15

Haha, this is exactly what I’ve just done…V6 is 3 times slower! Something must be wrong. What could it be?


(Steve Baer) #16

Ok, so this really isn’t isolated to the Move command and has more to do with Rhino V6 performance in general. We were going down the wrong path. Having the display actually improve in performance after turning GPU tessellation off is definitely a sign that this GPU really wasn’t designed to run at the OpenGL levels that the driver reports it being capable of.

I’ll look into adding a test command to force Rhino to run at a lower OpenGL level than what the card reports to see if the situation improves in these “legacy” modes.


#17

yep, obviously my GPU doesn’t handle it. So if there is some possibility to force Rhino V6 behave at least as V5 (in term of performance) it would be very appreciated! Unless until I obtain a new pc, thank you Steve


(Pcalifano) #18

Hello, I’m new with rhino. I have v6, my pc is a laptop with i7hq and gtx950m. I’m experiencing lag only when using commands like move, copy etc just like @petumatr… I also tried to disable tessellation and antialiasing, but I can’t find any difference… What could I try? It’s pretty annoying. Thank you
(I have no plugins, just an updated clean rhino version, and my gpu drivers are up-to-date)

UPDATE:
Okay, though it was a small cad drawind (I imported it from autoCAD), there was a layer with 31000 lines…
Since I swithed it off, the performances are really better. Also, I found that if I use only one viewport at a time, there’s no lag at all!
Anyway, I hope this issue won’t come back when I’ll work on bigger projects.
Thank you.