Help! Major lag with rhino and new computer!

Just upgraded my computer to a amd 2920x and 2080ti gpu so Im confused why Im getting crazy lag with such things like moving objects, ctrl+shift selection windows for solids, and dimension, etc. Even my 5 year old laptop works better. :sob: Please help! Is it settings? See this video…in the first bit, I show the dimensions problem, and in the last bit the major lag with ctrl+shift selection of a surface. Help! :frowning:
https://peterrz.tinytake.com/tt/MzYzODU1N18xMTAyNDcyNQ

Hi Peter - if the machine is new, please make sure to update Windows and the graphics drivers, if you have not - drivers are unlikely to be the latest on a new machine.

Also please run the SystemInfo command in Rhino and post (copy/paste) the results here.

-Pascal

Hi Pascal. I updated the graphics driver last week and windows is new, so it’s up to date.
Thank you\ for looking into this.
Here’s the systeminfo:

Rhino 6 SR15 2019-6-13 (Rhino 6, 6.15.19164.21011, Git hash:master @ e41c99d36bb5000377057645e96b3ea6facf6171)
License type: Commercial, build 2019-06-13
License details: Cloud Zoo. In use by: Peter ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-PJ0U1NE

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 5-22-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.86

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-22-2019
Driver Version: 26.21.14.3086
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Peter -

This is what jumps out at me - to test, try disabling Vray in Options > Plug-ins page and then restart Rhino.

-Pascal

Done. Unfortunately that didn’t help. Still lagging.

OK… can you bear with me and just verify that Vray is not loaded when you start Rhino? Just making sure because your description matches, to my recollection, symptoms that appeared to be related to Vray in other cases.

-Pascal

how do i confirm?

Sorry - open Options > Plug-ins page and look for that plug-in - it should not be enabled (check box) or loaded.
Oh, and you might get the latest SR of Rhino too - 6.16 is current.

-Pascal

Thanks. Confirmed. The vray plugin is unchecked. Also, currently on 6.15…and update says Im current.

If you have any other suggestions, Im all eyes

Uncheck all plug-ins?

Ill try it… but for a computer this powerful to run weaker than my old laptop … Im speechless

Hi Peter - first, start in Safe Mode

Start Rhino in Safe Mode: Windows start menu, type in ‘Rhinoceros’ and look for the ‘Rhinoceros in Safe Mode’ entry.

And see how things behave. This is a test mode and not meant to be a working mode.

Does the problem you are seeing happen in any file - like a new file with a few objects added - or only some files?

-Pascal

Thanks Pascal. Im working on a new file now so things are ok, but still a bit slugish in layout when I make views using arctic mode. Are there any windows settings to ensure my computer is being used to it’s full potential? Anything Im missing maybe in rhino settings? Do I set the “rhino render options” maybe? I don’t know what I don’t know, you know what I mean? What am I missing? I just don’t believe that this computer would run a fresh install of rhino slugishly.

R6 UI is noticeably slower than R5. I notice it here too. I know that it attributes to bunch of neat features like RichText formatting and such. Display though should be much faster.

1 Like