File Opening: V8 WIP

I thought i would try the V8 WIP in my brand new ARM Macbook.

When I open a file, it goes to 100% CPU and stays there. File never opens.
Reboot and the same thing happens.

You’ll probably want to start by posting the results of _SystemInfo. If opening a new document also fails I’m going to hazard a guess you’re on Ventura. FWIW opening files using Rhino 8 WIP on my aging M1 laptop with MacOS 12.6 works just fine.

I’d reported something similar before. Big files of a couple of GB simply won’t open.
Haven’t checked lately though.

I tried with a 4.6GB file

It loaded no problem, maybe even quicker than on my Windows machine.

Note though that when you open large files you may run into memory compression and swapping, which significantly slow down applications, especially those applications whose memory is being compressed and/or swapped.

The files I have tried are are hundreds of MB. 200MB-400M.

I have 64GB memory. I have yet to see any swap used.

The largest loads in about 5 seconds on V7.

Import on the files has the same problem.
If have seen some files take forever to load on V7 that will import immediately. Not the case here.

hino 7 SR23 2022-10-9 (Rhino 7, 7.23.22282.13002, Git hash:master @ a931168ca9426920ae6aa97218710b662f17fc39)
License type: Commercial, build 2022-10-09
License details: Cloud Zoo

Apple macOS Version 12.6.1 (Build 21G217) (Physical RAM: 64Gb)
Rhino is running in Rosetta2 on Apple Silicon
Mac Model Identifier: MacBookPro18,2
Language: en-US (MacOS default)

Apple M1 Max (OpenGL ver:4.1 Metal - 76.3)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Apple
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 48 GB
Graphics: Apple M1 Max
Displays: Unknown (255dpi 2x)

Graphics processors
Apple M1 Max
Color LCD (1728 x 1117 @ 120.00Hz)

USB devices

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “RhinoCycles” 7.23.22282.13002
/Applications/Rhino “Snapshots” 7.23.22282.1002
/Applications/Rhino “Grasshopper” 7.23.22282.13002
/Applications/Rhino “PanelingTools” 7.23.22282.1002
/Applications/Rhino “AnimationTools” 7.23.22282.1002
/Applications/Rhino “Commands” 7.23.22282.13002
/Applications/Rhino “Renderer Development Kit” 7.23.22282.1002
/Applications/Rhino “RDK_EtoUI” 7.23.22282.13002
/Applications/Rhino “Displacement” 7.23.22282.1002
/Applications/Rhino “Rhino Render” 7.23.22282.13002
/Applications/Rhino “IronPython” 7.23.22282.13002
/Applications/Rhino “Legacy Rhino Render” 7.23.22282.1002

Same here. I’ve generally monitored memory usage on and off over the last few months, and there barely is any swapping going on on Apple Silicon with the Unified Memory and stuff.
Concerning Rhino, it seems to consume very few resources even if under load (i.e. lots of geometries), but also performs overall not that great. I’d rather have it dig into the resources and perform better.

I left the computer trying to open a file overnight. Rhino WIP was “not responding”. I killed it. It took several minutes for the process to go away. I have now seen that twice.

You probably should share a file that exhibits the problem. For confidential upload you can use Rhino - Upload to Support . Don’t forget to copy a link to this topic in the comments section so that tech support knows what it is about.

I’ve uploaded a few. Not making much progress with the WIP.

RH-71349 is fixed in the latest WIP

1 Like

@miano, your model now opens nice and quick on my M1.

1 Like