Fbx import fails each time into Rhino

Hi, V5
I export a textured file from agisoft metashape as fbx selecting export texture and embed texture options jpg. It opens in Autodesk viewer in colour (though dark, their lighting and viewing environment is poor).
It imports into Rhino as nothing except an error message at top. which says :-

Error importing file and the address to the fbx file.

I wanted to export it with dimensions and textures and to scale, so the measure tool in autodesk could be used, I cant give it a scale in metashape as no such means exists there.

Rhino is my only means of giving it scale and it wont open it with a texture embedded, the obj method failed as Rhino failed to bring in the jpg file from the same folder the obj was in.

What to do to fix the fbx or obj issues ?

can I get Rhino to export it with the colour image it does have, same quality as ‘model shaded’ in metashape which is very nice anyway. How do I get that turned into a colour image that survives with the fbx export from Rhino ?

here is the fbx, oh its 27Mb so cant attach. anyway I turn I am scuppered.


Hmmm, I’m wondering if the version of FBX Metashape is saving is newer than Rhino 5 can read.
Do you have the option to save to an earlier version of FBX?

Afraid not.
I do have photoscan by them the old prog prior to Metashape, I would have to redo the entire project in photoscan as it might have an old export fbx .

I think I am going to have to do so as metashape is festooned with issues here, from blurred textures to obj’s anf fbx’s that dont work.

Photoscan always seems to fix the problems.

Yet it feels wrong to not use the new version which should be well improved, it is quicker thats for sure.
Whole day getting nowhere, achieved nothing so may as well see whats going on.

I should perhaps just stick with Photoscan but they will say should have used metashape if I do get a problem.

I am so limited for time and a week spent on 3D generation is not good.
Even Autodesk is a lousy viewer,

Now trying all over again on Photoscan.



Before you go to the trouble of redoing the project in Photoscan, you might be able to convert the FBX to an earlier version.
AutoDesk has a free app called FBX Review that might do it.

photoscan has no mesh from depth map, so far the model is a brown mush .

very slow going.

will try for that, metashape has tools missing in photoscan and p’scan looks archaic now.


found it , win 64 bit but OS 8 or 10 and I am 7.
Back to the drawing board.


I have redone the project in Photoscan. used the create texture command, looks nice no blurred areas at all.

Photoscan better then metashape as such. I find this again and again on things.

I export as obj, it makes 3 files obj mtl and jpg.

I create new file in rhino and import the obj, it shows only the obj file, no chance of selecting the other two, (note Autodesk asks for any more files)

it opens and in rendered mode its just silvery grey !

hells bells .

so an earlier obj version is made and no colours are seen., at least metashape obj opened with the non texture colours which are workable to.

Getting nowhere.

Surely opening a model with texture anywhere on a pc or internet shouldnt be this hard ?

Why does Rhino not even ask for the other files ?

Lets try for the reason behind using Photoscan, to make an earlier fbx file.
Import it into Rhino and we get this:-

I even see chinese lettering, Covid has invaded PC !!!
So an earlier fbx fails miserably.

very disheartening is all this 1.5 days now spent trying to open a 3D file with texture either into Rhino or online. (David Cockey uses obj so I wonder how he gets on !)

update, one day later of trying to view a mesh with texture, still nowhere, I have installed fbx viewer by autodesk, no ability to save as earlier, or measure , just a viewer.

I download Autodesk fbx converter, virustotal finds a red warning about it.

analyse a Autodesk Meshmixer from 2016 and again has red warning on content.

Crazy as it sounds, The simple task of viewing a mesh with texture is NOT POSSIBLE unless anyone knows a way.
3 days on this now.


Its curious that the OBJ model with texture is not opening in Rhino with the texture.
Maybe Metashape is saving a specific path in the MTL that references folder structure on your computer?

Can you post the MTL file?

here is the mtl file
had to zip it as file type disallowed (wasnt visible , not approved list etc !)
nuts !
RAF Type E bomb trolley 2 chunks steering and hand brake v4 texture made export steering.zip (499 Bytes)



The MTL file says your image name is:
RAF Type E bomb trolley 2 chunks steering and hand brake v4 texture made export steering.jpg

Does the file name of your image actually have spaces as shown, or does it have underscores “_” instead of spaces?

it has spaces, thats the same name as the metashape project title.

Nothing is ever said about removing spaces, thats old school win93 days. win7 has moved on since then.


Spaces are OK, the image file name in the MTL file must match the actual image name.
The MTL file name in the OBJ file must match the actual MTL file name.
As long as you haven’t changed any of the file names it should be OK

When you open the OBJ file in Rhino, make sure that ignore textures is unchecked
You also have to change the view to Rendered


I am unable to open a mtl as I dont know how,.

here are the 3 files metashape created.:-1:

Again no idea how to look inside an obj to see the file name.

I havent so the two above should be ok, so why doesnt it work ?

Opening an obj I do leave the Ignore textures box unticked.and I am viewing in Rendered.

so as such all rules met and yet Rhino fails to open the texture.

Have you managed to get the texture to open ?

The obj mtl and jpg when zipped. is 28Mb, how can I get this to you to see how it opens in your Rhino ?


Steve, Can you PM me your email address, I’ll send you a dropbox link.

opening an obj is solved here:-

not sure of fbx yet.


certainly solved the obj missing texture by the method shown by wim.

await results , thanks for doing this.

However I now come to draw over it in Rendered mode. onto a cyan layer, and I get a very light grey in fact white almost result, as rendered mode doesnt display colours from such layers, so another post to be made to solve that !


Thanks for the 3 files, obj, fbx and obj from meta 1.7.3

obj opens with texture
fbx opens with texture
1.7.4 opens with texture.

so yours have texture and if I try for that, new file small inches file import file v5 etc .fbx and it says error.

try for the v5…obj and it opens, with texture, so how is it that yours have texture, mine now have texture though the fbx errored ? Tried it again and error.

it says error importing file then gives the address on my PC. I try another and same thing.

Wim said to browse to and apply the texture in properties materials, but now its applying it upon import.
Not sure why its doing so now in a new file.


I’m guessing its because I’m using Rhino7 and it handles the import differently, I exported these to v5

Its possible the FBX from Metashape is newer than the version of FBX supported by Rhino5

probably so, I couldnt find a way of making an earlier fbx.

I did try an earlier version, namely photoscan, but then the fbx opened almost pure white.

I havent actually found a viewer yet for the file.

I wonder should I export it from Rhino, as it now has scale, its the right size, so need to apply scale in meshlab, but how to get it viewable to anyone and purely them and no one else. in the correct appearance.
Online leaves texture behind. FBX export from Rhino is my next hope. what else would contain the texture ?
I see fbx, and here are the options, what do I choose for best performance my mesh and my drawn solids and curves ?
fbx export options in v5

Online viewers the three that appear atop google when search fbx online viewer, all fail miserably, the texture is absent yet fbx should include it.

I then try lambert but no better, no texture appears so fbx that supposed to take texture ceases t0 do so from Rhino.