How can I draw and model in colour in rendered mode?

I have thanks to wim been able to get a texture to appear on the mesh from the imported .obj file.
When in rendered mode.

I now need to use the details on this textured mesh and start drawing and recreating the item with surfaces etc using Rhino tools and layers as we all do in shaded mode but instead in rendered mode. I have never drawn and built things in rendered mode before as everything is in shades of grey.

I create a cyan layer, drag out a box and its white ?
its cyan in shaded mode. I need to see cyan.

my cyan box is white.

How can I do this ?

if impossible to get layer colours to appear when drawing on them in rendered mode, then the texture will have to appear in shaded mode. !
Rhino at least does show a texture there, its the ‘not quite as crisp one’ that metashape also shows in its ‘shaded model’ mode.

Any idea how I can get the texture.jpg to end up in shaded mode mapped to the mesh and looking crisp , how is that colour image from metashape shaded mode (its not a texture file applied via materials, wim method, but all the images still mapped to the model, just not quite as crisp,) is managing to show in Rhino shaded mode ?

Else the advantage of displaying the texture jpg for tracing the detail is gone if I can only work in shades of grey.

David Cockey uses worksession mode, a new file for the draw and attach the rhino file with mesh in, tried that, but no it also fails. cyan box is white.


Hello - I am not sure if I can distill out the real question here but I think SetObjectDisplayMode >Rendered may help.


… or just assign a material to your layers and model in Rendered mode.


Thats it, I can draw in colour with many layers each its own colour, red for cutters , orange datum etc.
you have solved it, I never knew an object could be given a different mode like that. because I have never been in this situation before, modelling with mesh as a reference.
David Cockey gets his mesh to correct size then uses worksession, creating a new file for the geometry and pulling the mesh in as uneditable reference, but in order to even get this mesh to correct size to be that reference file I needed a few items drawn on/in it to establish the parts I had measured.

Would worksession make the drawing file easier to save, takes a while to do a save of this file, what are the advantages of davids way ?


You have lost me there, any chance of a step by step, not sure how to assign a material to my drawing layer, what material to assign, then drawing in rendered mode. Pascal’s gives me access to all the tools and layers colours everything I have so far ever done. If I draw in rendered mode I need to see colours, many of them, for all the layers I create, I have lost the white background, my normal working environment etc.

Guys, if I want to make the reference item translucent, as here we see my objects ‘within’ the item, I could do with seeing them in a ghosted fashion within, as I draw. How is that done. I tried selecting it and in properties transparency slider but nothing happened, then a tranny value in colour, then the setting below, still nothing.



Hi Steve -

In your Layer panel, there is a column for “Material”. If you click on the circle for the layer that you are using, the Layer Material dialog will pop up. Here, you can simply assign a color in the Basic Settings > Color option. That can be the same setting as your layer color but it could be a different one.

Shaded display mode:

Rendered display mode:


Thanks Wim, I never knew that trick, never needed this before though, all new territory.

I have been working towards Object capture and recreating with tools in Rhino for years.

When they fix Metashape then BINGO.

How can I make the mesh and texture a bit translucent, as asked, so as to see my objects I am forming within it as often they are, as we see here, part hidden. Tricky building referencing them when they are hidden !
I need to learn what tools and snaps ignore mesh and what tools ignore anything but mesh.


Hi @Steve1 ,

Use SetObjectDisplayMode and set that mesh with the vertex colors to Ghosted. Then adjust the Ghosted display mode settings in Options to not show mesh wires. I believe that will do what you want here for semi transparent tracing.

I select my mesh with a few curves now drawn on it and grouped. run SetObjectDisplayMode choose ghosted and its now a purple , I cant see the texture at all. I go into file>properties and display modes and ghosted and untick show mesh, its still purple. I try for layers palette and click materials and apply 80% but nothing changes.

So I am doing something wrong I guess.

I want to see the texture but with some transparency to it ditto the mesh, else when I draw a solid its hidden within.

The other thing is having drawn some reference lines such as cross sections to help align it to another mesh with same, selecting sees a yellow blinding mass, I cant see my lines, I need the mesh to be there but subdued along with its texture, to see my curves clearly.

How can I have these reference curves/cross sections and move the item without the whole thing going yellow and as such I cannot see a thing !!!


Hi @Steve1,

Maybe your Ghosted mode was not set to the defaults? Try this ini file by importing it into your Display Modes in Options > View > Display Modes. It is Ghosted mode with Mesh Wires disabled and I also enabled the shade highlight selected meshes option so you could see the mesh when it was selected rather than all yellow.

Ghosted.ini (13.3 KB)

1 Like