Failed to save as fbx

Rhino Support,

We are trying to convert a .sldasm to .fbx by saving the file as a .fbx. This procedure seems to work with other .sldasm files however one of our files is causing issues and we need this to work consistently. We get an error “Failed to save as .fbx. The file writing plug-in failed.”. Can you help us figure out why this is occurring as it is holding up automation efforts for the company we work for. We already checked for updates and are on the latest plugins and version of Rhino. Thanks,


The WIP has the same issue.

maybe there are some issues in the surfaces so the meshing fail. Try to convert to mesh inside rhino each part and then export.

Hi Jeremy - please send the file to please include a link to this thread - if the file is large, please SaveSmall, and zip, and upload to, also with a link back here.


Hello All,

Thank you for the advice.

Diego, I was able to mesh everything fine but we are still getting the same error.

Pascal, I would if I could but I am unable to even with a signed NDA.


File does mesh and save correctly as an obj but I would still rather use fbx.

Currently fbx is failing in the meshing operation of the save or export.

Any other suggestions to help me out? Would the file size to big? Any other working processes?

Hi - can you reproduce the issue with a file that you can upload to us?

It is difficult to say. With some of the Solidworks 2017 service pack 4.1 assembly files I am now missing some components on import. If I import those components separately they come in without issue. I do not know if I can replicate these issues since the assemblies I am using are 50+ parts large and contain sub-assemblies. To replicate this effect with open source files would take some time. I would be more than willing to share comparison images if give a send to link. Also If you think it would help to upgrade Solidworks I could try that too. @wim

Solved the issue. First thing to check for is bad objects. Run SelBadObjects and delete them as long as they do not hinder the appearance of the object.

Hi Jeremy - thanks for that follow-up!

If I’m reading this thread correctly, there were two separate issues: (1) the initial one where objects that were imported into Rhino did not export as FBX, and (2) an issue where not all components of a .sldasm file were imported into Rhino.

Could you clarify what was solved?

It has solved the issue of saving files as a fbx. If there are bad geometries present the export will fail. I created a separate post for the other issue to keep this one to a single problem.