ELK & Heron || solution for : -‘OSGeo.GDAL.GdalPINVOKE’ threw an exception-

unhandled

( Charles C.) #1

I ran couple times throught that error and can’t find any solution

error message from Heron or Elk : ‘OSGeo.GDAL.GdalPINVOKE’ threw an exception.

This solution worked 5 minutes for me -.-’ :

  1. I removed every folders, gha component, .dll etc from the grasshopper component folder (where every plugin component are installed).
    For me it was C:\Users\Charles\AppData\Roaming\Grasshopper\Libraries

  2. I put back ONLY the Heron folder. I give it a try and the plugin worked just fine.

  3. Then I put back all the other plugins I had

It worked correctly, then 5 min later throw me the same error …

I think plugins may interfere together causing that error


Unknown error in Grasshopper with Elk plugin
( Charles C.) #2

Update

Having gismo gismo component or Ladybug Ladybug component flying/running when opening the grasshopper file cause the ‘OSGeo.GDAL.GdalPINVOKE’ threw an exception’.

solution: disable these components in your GHdefinition. Save it. Restart Rhino. Open the Ghfile. Enable them. Everything is suppose to work.


Gismo and Heron matching