Unknown error in Grasshopper with Elk plugin

grasshopper
unhandled

(Courtney Reckord) #1

Hello all, I am all of the sudden running into an error with gh documents that have been working fine up to today.
i am getting this error message

  1. Solution exception:The type initializer for ‘OSGeo.GDAL.GdalPINVOKE’ threw an exception.
    I have googled it but can’t find a solution.
    Is anyone else having the same issue?
    thanks in advance.

(rez) #2

Hi, in the meanwhile that you find a solution try Gismo.
It does pretty much the same things


(Wim Dekeyser) #3

Trying Gismo would be a good thing to try - if nothing else to check if it’s something with the GDAL libraries on your computer. Both ELK and Gismo rely on these libraries…
Simply going through the installation process for Gismo might therefore solve the problem with ELK for you.


( Charles C.) #4

Did it finally work ? I get the same error message in Elk and Heron too


(Courtney Reckord) #5

Hi @billytalent.exe - I think so! I honestly don’t remember how I solved it - so sorry!
I didn’t use Gismo though, I know that.


#7

Hi Charles.
When it comes to Rhino 5, both Heron and Elk work only on 64 bit version of it.
Gismo supports both 32 bit and 64 bit version of Rhino 5. Did you try to install Heron and Elk on Rhino 5 32 bit?


( Charles C.) #8

Hi djordje,
I found only 1 grasshopper folder on my PC. I suppose the folder is for the Rhino 64bit. So I have no clue how to install elk and Heron for Rhino32bits


#9

Hi Charles,
You can check your Rhino 5 version by selecting “Help -> About Rhinoceros” and then check what stands in the following window:

Rhino 6 does not have a 32 bit version.


( Charles C.) #11

new post here (thought I found a stable solution) : ELK & Heron || Solution for -‘OSGeo.GDAL.GdalPINVOKE’ threw an exception-


#12

Thank you for the reply Charles.
Try Gismo, as it uses the same GDAL libraries, but keeps them in the separate folders.


( Charles C.) #13

@djordje,

If I’m not mistaking you’re the one who wrote the gismo plugin right ?
Until now, compare to Heron, Elk and Ladybug TerrainGenerator, the gismo TerrainGenerator component is the one which is always working regardless of the site (is not throwing me some errors) !

The only thing, why I’m not using so much is because I can’t easily map an High resolution image on the topography… Do you think its something that would take a lot of time to add to your TG component ?

Also, I reed couple post about you and Antonello talking about Terrain Generator. Which one of them I might use Gismo TG or LB TG? Knowing that LB terrain generator extracting is data from Google elevation API (based mostly on SRTM .IMG or .HGT files) the generated topography has a resolution around 20-30 meters (correct?). Your gismo TerrainGenerator is doing the same ?

Thank you :wink:
Charles C.


#15

Hi @billytalent.exe

Please accept my apology for the late reply.

Gismo at the moment has 4 people who created its components.

Here are some of the comparisons of Ladybug and Gismo Terrain Generator.

Ladybug Terrain Generator

  • higher terrain resolution in urban areas!
    I am not familiar with Google Maps terrain sources, as I do not think they ever released this data. There are only guesses. You are definitively correct that SRTM 1 arc second is one of them. This is approximately 20 to 30 meters resolution.
    Still in urban areas, they use Lidar data which can be just a few (3,4,5…) meters resolution. We do not have sources for which cities this Lidar data exists, but they seem to have covered quite a lot.
  • radius up too a couple of hundreds of meters. The radius can be even larger than this, but then the upper mentioned Lidar precision deteriorates.
  • satellite imagery is available!
  • from 12.06.2018 you will need to register for Google API key in order to use the component. (This information needs confirmation from the author of the component: @AntonelloDN ).

Gismo Terrain Generator

  • lower terrain resolution. No Lidar data available! The resolution is always 1 arc second (approximately 20 to 30 meters).
  • higher radius. Radii up to 100 km is supported.
  • no satellite imagery!
  • underwater terrain available (even though the resolution is a bit coarse: from 50 to 2000 meters)
  • no API key needed.

( Charles C.) #16

Thank you very much for these precisions @djordje !