Moving detail and dimension breaks history in V6

Hello,

I want to ask why dragging detail view together with dimensions break history at the first place? I would understand that if only detail view was dragged but not when everything is dragged at once.

Thanks

Hello - This is true in V6, not in V7 and later. The rule for modifying the child breaking history is ignored in V7 for dimensions.

-Pascal

if we talk about the same thing it is happening in V7 as well.

i have rectangle in model space and added a dimension in layout space.


I select everythng (detail view+dimension) drag and:

I dont get it why it should break anything when i move everything. Nothing is left behind so what is there to be broken?

Hello - that does not happen here - I can move both. The reason it would happen is that in moving the dimension, you are changing a child object - that normally breaks history - as when in V6 nd earlier V7s, you move both parent and child of say, and extruded curve.

If you are seeing this in V7, there is something wrong, I would say, unless that behavior is more recent than I thought… - can you please run the SystemInfo command in Rhino and post the results?

-Pascal

Rhino 7 SR12 2021-10-19 (Rhino 7, 7.12.21292.05001, Git hash:master @ be96e40b49e788c8356e6766063ef690e4694366)
License type: Commercial, build 2021-10-19
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Unplugged [68% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-25-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1050 Ti with Max-Q Design (NVidia) Memory: 4GB, Driver date: 10-26-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.47
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2021
Driver Version: 30.0.14.7247
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Geometry Gym\Rhino3d\ggRhinoIFC.rhp “ggRhinoIFC” 1.7.58.0
C:\Program Files\Geometry Gym\Rhino3d\BullAnt.rhp “bullant” 1.4.4.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21292.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21292.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21292.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21292.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21292.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\ivan_galik\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

Hm - I would disable these in Options > Plug-ins page and then close and restart Rhino and see if anything changes.

-Pascal

I found out when i only select detail view and drag, no history is broken and the dim is moved around together with detail view even though its not selected.
if i select both detail view and the dim then the history is broken. i still find it strange.

Right, it is strange - and not correct as far as I know.

-Pascal