Leaders, dimensions and history

Hi we are having a real problem here in V6 with dimensions and leaders in Layouts getting screwed up when underlying geometry (I guess that they are linked to) changing.

Right clicking on ‘History’ says history is turned off but the dimensions and geometry still seem linked. Is there a way to turn history off ‘more’? It’s frustrating to get a drawing near completion, fuss with a surface or some lines in model space then discover on printing that dimensions or leaders have flown way off the page.

Eric

1 Like

Hi,

Here is an example of 2 leaders that jumped off the sheet after editing something in model space (not sure what). This is in Rhino 6 btw if this not in the right forum.

Moving the leaders back where they belong gives the “History Broken” error msg.

1 Like

Dimensions in V6 are always “history enabled”. There is no way currently to turn it off.

That said, I don’t see how disabling history would fix this issue.
Without it, then every tweak of model geometry would cause dimensions in the model or a layout to be “dumb” and not move with the geometry change.

I’ve had a lot of annotations ‘moving’ when creating a detail window in layouts :frowning:

1 Like

Hi John,

Right now we’re thinking ‘dumb’ dimensions would be preferable.

Eric

2 Likes

Why? What would that solve?
Wouldn’t the “cure” be worse than the “disease”?

I’m trying to understand the real underlying problem.

We didn’t have problems working in V5 which didn’t have the dimensions linked. Now we have problems.

Eric

1 Like

The changes to annotations between V5 and V6 were so profound, turning off history is not the likely fix.

What I really need is a small sample file and set of steps to follow that exhibit this problem.
I know that’s going to be hard to nail down, but it’s very likely the actual problem and resulting fix are not history related.

Completely agree, it’s a great feature if it is dependable. I’ll work on nailing down an example.

Eric

1 Like

Hi John, here is an example of the leader issue.

Thanks,

Ericloose leader example.3dm (46.7 KB)

Perfect!
I can repeat it.
Thanks

https://mcneel.myjetbrains.com/youtrack/issue/RH-45627

The developer thinks it’s most likely a problem with History trying to update the leader when the curve changes.

@eej
I just tried this in today’s in-house build which is becoming SR5, and the problem is gone.
Whatever was causing this has already been fixed.

Hi John,
I feel exactly the same as @eej !

I would much prefer “dumb” dimensions, because I run into this problem constantly in Rhino7.

As someone who LOVES Rhino, and works on it as my primary software for 12 hours a day (in the film industry in Vancouver), I would LOVE a way to simply switch OFF the “History” for dimensions and leaders.

I end up doing this work-around process to fix every one of my layout drawings:

  1. SelDim
  2. Move (right 1 inch)
  3. Click “Okay” to the broken dimension history alert.
  4. Move (left 1 inch)

…I do this to intentionally break all the connections from dimensions to the geometry.
(Otherwise I would spend tons of time fixing incorrect dimensions that have “linked” to the wrong thing, or flown off the page, like @eej showed above.)

1 Like

Hi Siri -

When you run the History command, you can set the RecordAnnotationHistory to No.
-wim

3 Likes

Hi There - yes - I am also getting this same issue in V7 on Mac, Also with leaders.

Rather frustrating, and would also be happy to have a function to make leaders and dims ‘dumb’ as such. - However your work flow @Siri helped resolve my issue - by Seldim / SelLeaders and then move 10mm left to break all connections / history, and then move 10mm Back, so I can then select all work and move it to a new location.

Thanks.