Copy and paste slow


#1

I am experiencing a lot of delay in the copy object ( CTRL C ) and paste ( CTRL V) operations, even with very simple objects ( one straight line, anything) in Rhino 6.0.

Anyone else having this trouble?

Thanks!
Luis


#2

Do you have any non-standard plug-ins installed?


(Pascal Golay) #3

Hi Luis - if you are using 6.0, please Check for updates (Help menu) and get the latest SR installed - does that behave any better?

-Pascal


#4

Hi,

No, just Flamingo xnT 5.

I have a slow system, but the same operations in Rhino 5 were faster.

Thanks for getting back!


#5

Latest version, installed yesterday. Thanks!


(Pascal Golay) #6

Hi Luis - if you just open a new empty file, make a box or something and Copy/Paste, is that slow?

-Pascal


#7

I will try that and let you know.


#8

In a very simple file becomes fast. So I guess my machine is struggling with the file sizes I am dealing with ( 130Mb more or less).

Thanks!


(Pascal Golay) #9

Hi Luis - I’m not sure that is the case - if you are copying small amounts of geometry, it should be fast in a large file as well as a small one I’d think, unless there is something else - another test would be to start Rhino in Safe Mode and open the large file - don’t let any third party plug-ins load, including nXt in this case. Open your large file and see if the behavior is different for Copy/paste.

-Pascal


#10

Thanks. I also thought that it should not be the case, because I worked with much larger files before, and usually I did not feel the problem. Now it is that slow that I already take my hands of the computer to wait. That used to happen sometimes with Rhino 5, but much less frequently. When I have done the tests I will get back.


#11

Hi Pascal,

I tried running in safe mode and not loading any plug ins. Maybe a trifle faster, but not normal, with the same 120Mb file.

I think there could be a little bug here.

Thanks again for your help,
Luis


#12

I went back to my work running the usual way ( not safe mode ) and definitively, it runs much slower for copy. The top bar even goes to (Not Responding).

It makes the command really troublesome to use, and I use it a lot.

So it may have to do with the plug ins, even though it does not work well even in safe mode, but it runs better.

Thanks!_


#13

Hi all, I may have a hint to what causes my copy and paste command to become slow in Rhino 6.0

I have been working with a R6 file that had never had something that had been part of a Rhino 5 file before. Copy and Paste worked at the speed you would expect it to work. But then I imported a file that contained some information I needed, just lines, no surfaces, and as soon as I did this, copy and paste started taking ages to work ( you feel the delay when the copy command is used ).

Would anyone have a clue as to what is causing this?

Here is my system info:

Rhino 6 SR9 2018-9-28 (Rhino 6, 6.9.18271.20591, Git hash:master @ 4cf7435f08f51c972347c8558d28355cfc0471ca)
Licence type: Commercial, build 2018-09-28
License details: Cloud Zoo. In use by: Luis Manuel Pinho ()

Windows 8.1 (Physical RAM: 5.9Gb)
Machine name: GREEN-NOMAD

Intel® HD Graphics 4000 (OpenGL ver:4.0.0 - Build 10.18.10.3308)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build 10.18.10.3308
Driver Date: 9-16-2013
Driver Version: 10.18.10.3308
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2112 MB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\Flamingo nXt 5.0 (fd53f8c4-546d-47d1-8820-e66c97645a97)\5.5.18018.1000\5.5\Legacy\Flamingo.Legacy.dll "Flamingo nXt Legacy File Reader " 5.5.18018.1000
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.9.18271.20591
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\Flamingo nXt 5.0 (fd53f8c4-546d-47d1-8820-e66c97645a97)\5.5.18353.6521\5.5\Flamingo.nXt.rhp “Flamingo nXt 5.5” 5.5.18353.6521

Thanks to all!


(Pascal Golay) #14

Hello - For a while, V6 had trouble with Copy/Paste if Snapshots were used in some cases - I see you’re using 6.9, which is quite a ways back - SR13 is current. Can you try updating to SR13 and see if things improve? And if not, can you please try disabling Flamingo in Options > Plug-ins, and then restart Rhino and see if it is any different?

-Pascal


#15

Hi Pascal,

Thanks for the tips. I had to roll back the latest ( at the time ) service release because it caused my display to go totally crazy. Maybe that does not happen with the latest now, but I am so busy that I did not try it. I will try disabling Flamingo. I am with you that it must be some property that is attached to the file when you render it, and in this file I had no elements that had been rendered before.