BUG: copy-paste very very slow in current build (5min 45sec)

unhandled

(Gustavo Fontana) #1

I’m noticing that using Crtl-C + Ctrl-V to duplicate geometry in place is very slow in this build, Rhino even goes in to (Not Responding) mode. I just copied and pasted a simple revolve and it took 5min 45sec. This was happening in last week’s build and I just updated to tonights weekly build and problem is still here.

G


(Pascal Golay) #2

Hi Gustavo - is this true in a new file with just the one object?

-Pascal


(Gustavo Fontana) #3

it’s true in multiple files, different objects. including pasting anything to a new file too.


(Pascal Golay) #4

Hi Gustavo - what I’m wondering about is a brand new file - actually brand new started with ‘No template’ - also slow? Needless to say, it ain’t happening here, yet…

-Pascal


(Gustavo Fontana) #5

I see, I think I’m narrowing thsi down to parts that have materials. I’ll emailed you an offending part exported by itself. I tried to import that file I sent you to a default new file (no custom template) and it took that crazy delay that brings my entire computer down.


(Pascal Golay) #6

Hi Gustavo - I added a bugtrack item with the file you sent me - I was able to reproduce the lag/stall.

thanks,

-Pascal


#7

Hi Pascal,

Was this bug/problem fixed? I’m experiencing verrrry slow - copy/save/autosave - on a R6.3 file

It is only happening on one particular file, a R5 saved as R6.

No bad geometry. Only PlugIn is VRay 3.6.

Over 5 mins on a 630MB file.

David