Copy and Paste Slow


#1

Just wondering here if anyone has any idea why Rhino 5 64bit copy and paste feature chugs the system whereas 32bit it was lightning fast? I’ve scoured the internet trying to solve this mystery and can’t figure it out.

Anyone please help!


(John Brock) #2

What type of objects and how many are you using Copy/Paste on?


(Pascal Golay) #3

Hi Will- are you using any non-default plug-ins on 64 bit?

-Pascal


(Dale Fugier) #4

I have heard of this happening when the file has render material bloat-age. What render plug-in(s) are you using?


#5

I have the same problem. It was taking about 50 seconds to do a simple cut and paste of even a small piece of geometry, when I reported it last month. At that time I had Maxwell and Flamingo as plugin renderers. I have since unloaded Maxwell and just have Flamingo. Now it takes 5-10 seconds.

It still is longer than it used to be.

Thank you.


#6

I have the normal standard plugins that come with Rhino 5. When I view the Document Properties-Plug-ins there’s a bunch that are checked. I use a program called Matrix and that’s where I noticed this slowdown so I returned to just Rhino 5 by itself and still saw the slowdown.

A list of loaded plug-ins are:

Alerter
BlendTargets
DotMatrix
gvMatrixCore
IdleProcessor
MatrixArt
Renderer Development Kit
Rhino Render
Rhino Toolbars and Menus
Rhino Script
System6HD3View
T-Splines
TSplinesUi
V-Ray for Matrix
Web Browser

As for the objects, I’ve tried both dense models and a simple curve. I’m on a super fast computer as well with a video card that was recommended for this type of thing. Just for the sake of it, I did try the same thing in 32 bit Rhino 5 as well and its so fast I have to look at the command line to verify that I did copy something. Paste itself always varies depending on how much you are pasting but the copying side of things is juuuust slow enough to drive me to the forums.


(Pascal Golay) #7

Hi Will- I guess the thing to try is tp launch Rhino by itself in Safe Mode and see if that makes a difference.

Start in SafeMode.
SafeMode starts Rhino without using accelerated graphics and without loading plug-ins
On the Windows Start Menu, click the item titled
Rhinoceros 5.0 in Safe Mode or
Rhinoceros 5.0 (64-bit) in Safe Mode

http://docs.mcneel.com/rhino/5/help/en-us/information/start_rhino_in_safe_mode.htm

Also, does Audit3dmFIle, on the file showing the problem, show many many materials?

-Pascal


#8

Narrowing things down a bit here.

Tried Safe Mode and things appear to stay the same but I did make a notable discovery.
Rhino 5 64 bit works perfectly until I load any of my saved files. Once I load anything I’ve built, it starts chugging. Even after I load something and start with a new scene, it will start chugging. It’s almost like all of my files have something that loads in the background of Rhino and slows it down. Only way to clear this issue is to restart Rhino entirely and the glitch is gone. Of course it reloads as soon as I have to work off an old file again though. 32 bit doesn’t care though and the glitch never appears at all.

There was an old issue I USED to have that mirrored this problem I’m having now, the only difference is the old one I could purge from my save files whereas this one I can’t. I’m not very technical here but it’s almost as if it was duplicating the entire network of shaders that ran in the background of Rhino itself. I don’t know what causes this but the old glitch you could clear this (or if I’m wrong this mystery glitch) off by pasting your object into a new scene and just simply re-saving it there. This doesn’t work anymore as it appears Copying an object brings EVERYTHING with it now.

I could be crazy a bit here but if someone has a way of at least clearing this, this would greatly improve the speed of the program for users like myself. It’s usable right now, it just doesn’t purr like a kitten either.


#9

I have this exact same problem. It can be very slow on the most basic of objects like lines, surfaces, etc. I do this a lot from one file to another.


(Pascal Golay) #10

Hi Will- can you run Audit3dmFile on one of the bad files and post the results here or to my attention at tech@mcneel.com.?

thanks,

-Pascal


#11

Hi,
I got similar problem,
I believe problem come from Gemvision Matrix plugins, specially "gvMatrixCore"
if your matrix dongle usb key connected to pc, and only run Rhino 5 - 32/64 loaded gvMatrixCore not give a “copy/paste” or “save/save as” working normal. if still same problem happen check your matrix dongle key, it may be broken, I know most user always keep it connected. somehow usb port problem can broke your dongle easly. it`s happened my first key.

if your matrix dongle usb key not connected to pc, and run rhino 5 - 32/64 looaded gvMatrixCore make a problem.
(I connect my matrix key to USB port when I need it)

My solution is not effective for always but its ok for me now, rhino5 go plugins manager settings, then disable gvMatrixCore and click "Ask to load disabled plug-ins" close rhino5, rhino5 will ask you do you want to load that plugin etc.... click "no" then open your file for study, I believe its help.

if any body know how can I disable gvMatrixCore plugin without “ask to load disabled…” before starting Rhino5 /64 it help to us.

thanks.


(John Brock) #12

Here’s a screenshot of the Options > Plug-ins page.
If you uncheck the “Ask…” option, you should not be prompted to load when starting.
That’s specifically what the tool is for.


#13

my plugin options screenshot


(John Brock) #14

That is precisely why you ARE being asked to load it.
You have the option set so you ARE asked.

Uncheck the Ask option and restart


#15

I want it, each time ASK to load disabled plug-ing, because, if I load gvMatrixCore plugin, my Rhino getting slow/freez copy/paste - save-export files.

if I dont load gvMatrixCore plugin, my rhino working well copy/past - save and export files. thats why I am try to find solution for

Matrix plugins always give hard time to rhino, if matrix USB key is not inserted to PC.


#16

The cut and paste does take a very very long time (sometimes about a minute!). It doesn’t seem that this was resolved. I have disabled the T-Splines plugin and turned of the "Ask to load disabled plugins but it is still taking an inordinate amount of time. I have read the posts and maybe I have missed something, was this problem ever resolved?


(John Brock) #17

Try this test:
Start plain Rhino (no Matrix) in Safe Mode. There are two shortcuts in the Rhinoceros Program group with Safe Mode in their name.
This wills tart Rhino without plug-ins or OpenGL graphics.
See if your Copy/Paste is normal speed or still slow.

Please report back what you find.