Command Prompt Cannot Be Shown from UI

I was experimenting with the Rhino 8 UI, and I closed the Command Prompt Panel/Toolbar/Container (whatever it is considered).

Since I have no command prompt, I cannot see to type the command to show the command prompt.

I’ve scoured every pulldown menu, every preference, every option, and searched the advanced section and there is no checkbox to show the command prompt.

How can I get it back using the UI?

Hi Jason -

Possibly the easiest way is to use the Window pull-down on the menu line to restore the default window layout:

If you have invested a lot in a custom window layout and have not saved that, I suppose you could be reluctant to using that option.

In that case, you can use the DisplayCommandPrompt command. I haven’t tested Rhino 4, but that command is available in Rhino 5 and is documented in the help file.

Finally, and just FWIW, while you can’t see the commands that you type when the command prompt is hidden, you can still use that method to run commands. You’d have to remember the options though…

1 Like

Do you have plans to put the missing checkbox to hide/show the command prompt back into Appearance settings (Rhino 7)?


If not, I will add UI to our JewelBeetle plugin to hide/show the command prompt.

Hi Jason -

I’ve reopened a bug report for this one:
RH-73624 The Command Prompt visibility checkbox is missing in V8


RH-73624 is fixed in the latest BETA

1 Like

After reading this and looking at the bug fix and my own experience, I don’t think you have fixed the actual problem posted by the OP because I have just had the same issue. Or at least it is not resolved in the Mac version.

It is not a matter of voluntarily wanting to turn the command field on and off. The problem occurs when you undock the Main toolbar while messing around with the interface and then decide to close the toolbar.

If you go back the Toolbars dialog to choose to display the Main toolbar, the command input window does not show up any longer at the top of the Main toolbar as it does in the default Main toolbar display.

On a Mac there is no way that I can find any way to get the command input field to reappear back in the Main toolbar container other than resetting the interface to default.

Yes, I can just start typing and the command field pops up and so does the main toolbar container, but it pops up in the middle of the display and then remains locked in place! It can’t be moved back to the standard location on the left sidebar, so I just have to close it. Possibly that is a 2nd bug to fix…

Not to derail this, but while on the topic of command lines entry, is there a way to get the command line window to display on a Mac the old school way it does on Windows rather than a dialog box style?