Cannot turn off preview of Grasshopper object in rendered mode

The same for Arctic & Raytraced.

Yep, it’s not previews in Rendered modes (Rendered, Raytraced, Arctic, …) but the geometry is actually added to the Rhino display pipeline. At this point it’s out of my hands, although you can still disable this on a per-custom-preview-component-basis via the custom-preview-component context menu.