Grasshopper always dispalying geometry in Render/Arctic mode

Hi guys,

I have noticed this a while ago and it didn’t bother me enough to post about it, but today…it was the drop that spilled the cup.

For some reason, even when all components have their preview disabled in GH,and even when the “don’t draw any preview geometry” mode is selected, when I switch to Rendered mode in my viewport, I see GH’s geometry.

This issue has pushed me into workarounds several times.

The solution is to close the definition, but sometimes I don’t what to do that. So then I need to move all my baked geometry away from the 0,0,0 to get a nice view to export. Other times this is not enough and I just export my baked geometry into a whole new document an take a viewcapture from there. Imagine that: select>export>choose location>save>go to location>double click>wait for rhino to open>set view>set camera>viewcapture.

All that because of this…

Hope this can be fixed soon so that we, users, are able to tell GH than when we want no geometry to be drawn it means ABSOLUTELY NO GEOMETRY IN ANY VIEWPORT EVER!

For me only the preview material component displays even when preview is off in rendered and arctic. I usually just disable the preview component to hide it. Other components dont display when preview is off in rendered or arctic.

Ooh, so its that component alone. Yes, disabling them should do it then. Thanks Micheal, thats a much more efficient solution.

The Custom Preview component in v6 has two options to play with: the age-old preview, and rendered. Turn off Rendered to have it stop sending meshed data to Rendered and Arctic (and Raytraced) viewport.