Grasshopper hidden previews showing in render mode

unhandled

#1

Usually grashopper objects won’t show up in rendered mode, but i’ve noticed that in rhino 6, after baking one object from grasshopper, everything in grasshopper becomes visible in rhino rendered mode.
as seen in this screenshot


note, everything in grasshopper is turned to hidden preview.

Is this a bug or is there some kind of setting?


#2

For the rendering display mode (and some others), you’ll have to disable the rendering option in the custom preview component as well.
You can read more about that in this recent thread: