BUG: Rendered viewport ignores grasshopper preview settings

unhandled

(Andrew Heumann) #1

Grasshopper geometry fed into a Custom Preview component in the Beta shows up in the rendered viewport even if grasshopper preview display is off.


(Andrew Heumann) #2

I will say tho - having GH geometry preview in the rendered viewport is AWESOME! so amazing work on that :slight_smile:


(Andrew Heumann) #3

Never got any answer on this - is this by design? It seems a little counter-intuitive.


(Wim Dekeyser) #4

When I tried to reproduce this one, I all of a sudden remembered this one…

That is - currently - when there is no native Rhino geometry in the scene, Grasshopper geometry, in Rendered mode, is not visible. Regardless shading mode in GH. I’m not sure if these are two different issues or the same one. I agree that it’s not as it should be.


(Laurent Delrieu) #5

Hi Andrew
It is also a bit strange for me but there is a little check box when you right click the component. It enables or not the render.


(Wim Dekeyser) #6

But that just overrides the overall GH drawing setting.


(Andrew Heumann) #7

that sounds an awful lot like a bounding box problem - the GH geometry isn’t setting the scene bounding box properly. Just a guess!