Wish: Grasshopper preview to be shown in rendered mode

Hi I can not find a way to show grasshopper stuff in rendered mode and would love that.
Having to bake the geometry before evaluating in Rendered or Arctic isn’t a good workflow :slight_smile:


You don’t have to bake, but put your geometry into a custom preview node and all should be fine and well.


Now where to mindmap the logical name “custom preview”… hm… postit on right monitor should do. :slight_smile:

Hmm… Something seems to be wrong with my preview. I use custom preview and get a weird black preview which disappears when I rotate in certain angles.

I can change the color of the preview but it looks like the shadows are inverted?

Can you share your file for investigation?

When I internalise the data into grasshopper I have the same problem…

171122 Preview.gh (42.7 KB)

I also posted a seemingly related issue to this here Cannot turn off preview of Grasshopper object in rendered mode

Scrolling in and out on the same file as above here turned the same object black.

This looks a bit like funky geometry combined with a glossy material.

I tried your GH file, but (apart from the poor meshed internalized data) it looks probably as expected:

Can you try adding a material in Rhino through the material editor, then select that as material in the shader input for Custom Preview?

@davidrutten, looks like the type of the material gets decided wrongly. The plaster material shows up in GH as gem…

Strange. There’s only a few basic extrusions in there, nothing else.

Here’s when I use the plastic material with a green color. Shadows are still grey.

When I rotate I have the same issues of disappearing preview.

Now when I draw something in Rhino, I can rotate around without the preview breaking.

As soon as I delete the object I drew in Rhino, the preview breaks again when rotating.

I’ve just updated to 6.0.17332.10241 and i’m unable to display ‘2d’-type elements such as Points and Curves in either the Shaded or Rendered views even when plugged into a Custom Preview component … they only appear in the Wireframe view. I’m using a script i last worked on a couple of v6 builds ago and i am sure these were visible in both of those modes back then

Additionally, there seems to be a bug with the Custom Preview … the attached wireframe image shows that the Black color in the Swatch is only being applied to the first of the perimeter curves in the geometry list

Still the same issue here in the latest version… This is rendered mode.

@DavidRutten, @DavidEranen can either of you reproduce?

I can reproduce in the sense that I can’t get skylight shadows to work at all - I only see a solidly colored object.

@DavidRutten @andy Has this worked before?

So the gray shadows in rhino rendering mode has been solved.

But I’m still getting this same issue from grasshopper. I just tried the file I posted before here after resetting to default settings in rendered mode.

Also making a new file creates the same problem.

Here’s system information from the Rhino’s Help menu:

> Rhino 6 SR0 2017-11-28 (Rhino WIP, 6.0.17332.10241, Git hash:master @ 9359b47f5eb8d52c08ca047420e2fe6f08347939)
> Windows 7 SP1 (Physical RAM: 16Gb)
> Quadro M2000M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 385.08)
> OpenGL Settings
>   Safe mode: Off
>   Use accelerated hardware modes: On
>   Redraw scene when viewports are exposed: On
>   Anti-alias mode: 8x
>   Mip Map Filtering: Linear
>   Anisotropic Filtering Mode: Height
>   Vendor Name: NVIDIA Corporation
>   Render version: 4.5
>   Shading Language: 4.50 NVIDIA
>   Driver Date: 7-25-2017
>   Driver Version:
>   Maximum Texture size: 16384 x 16384
>   Z-Buffer depth: 24 bits
>   Maximum Viewport size: 16384 x 16384
>   Total Video Memory: 4 GB
> C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp	"Commands"	
> C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp	"WebBrowser"	
> C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp	"Renderer Development Kit"	
> C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp	"RhinoScript"	
> C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp	"IdleProcessor"	
> C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp	"Rhino Render"	
> C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	
> C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
> C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
> C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp	"Alerter"	
> C:\Program Files\Rhino WIP\Plug-ins\IronPython\RhinoDLR_Python.rhp	"IronPython"	
> C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	
> C:\Program Files\Rhino WIP\Plug-ins\Grasshopper\GrasshopperPlugin.rhp	"Grasshopper"	
> C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	
> C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
> C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp	"Displacement"

Here’s a video showing how it looks when I rotate, if that helps.

Am I by the way really the only one with this issue? Because then I’m starting to wonder if it’s something wrong with my machine, and it wouldn’t make sense to have you guys at McNeel wasting your time on it…

Hei Siemen,
Nope, you are not alone on this one.

When other (Rhino) objects are in the scene:

Same viewpoint but with those Rhino objects hidden:

At some point, I got the box to paint completely black but as soon as I rotated the view, it painted with material again and I wasn’t able to get it to be black again…

Still some problem with custom preview in Rhino Viewport !!

But curves & points from grasshopper don’t show up at all in rendered mode… Why?