Can not retrive Rhino 6 license from License Manager

After running Rhino 6 for a while on my laptop, I can not open a new session any more. The splash screen is showing “Retriving License from License Manager” and another dialog says “Contacting McNeel Servers…”

Update
After trying to enter the license key again and being advised not to do so for a multi-seat license, I closed all the dialog boxes, started Rhino 6 again and this time it opened. If my computer finally managed to retrieve the license, I took very long (since yesterday, when I could not demonstrate Rhino 6 because it wouldn’t open).

Same problem here.
This SUCKS !!!

Hi @osuire,

This is usually a Windows bug affecting some users.

If you are running 6.3 and earlier, you can reset your default browser in Windows:
https://support.microsoft.com/en-us/help/4028606/windows-10-change-your-default-browser

Otherwise, you can update to 6.4 where we bypass this Windows bug. (Recommended!)

Oh, so you made a change from a perfectly working system to a system relying on Windows ?
Smart move.

If I recall correctly, running Rhino requires relying on Windows… except for the Mac version, of course.

No. The other way around. 6.3 and earlier relied on Windows launching a browser. Sometimes that failed. 6.4 fixes it.

I’m experiencing the same issue using 6.6.18177. Tried resetting the browser back to default, no love. I can log into my account in a browser, but when launching Rhino 6 the splash screen is stuck displaying “Retrieving License from License Manger…”

Private message sent.

resolved. thank you.

Did I guess correctly as to the cause and fix?

Not sure.
I didn’t actually alter anything on my other machine (TRAMP), but things seemed to eventually resolve themselves.

My diagnosis processes was thoroughly un-scientific: It could a have been me letting it search for the server for long enough (I let it run for something like 10m), or could have been my various pokings and proddings of the website (I switched default browser, logged off and then back on again using the web interface).

Still getting the silly “Can’t retrieve license” thing.
It happened the other day while I was giving a presentation to my boss.
He said : “C’est quoi cette merde ?”

Exactly what I think every time I see this license thing pop up. :smile:

I am experiencing this with:
Version 6 SR12
(6.12.19029.6381, 1/29/2019)

Changing the default browser has not yet helped.
I’ve removed the license and re-assigned it to my account ans till get the same message.

Hi @sdoe73,

Welcome to the community!

Can you please post a screenshot of your situation?

This happens for about 10 minutes…

Then this pops up…

After clicking the “Login as” this pops up for about 10 min.

Then this pops up again and will just cycle…

I can re-enter the license key, I can logout and nothing corrects this. It just goes back to the first screen.

Are you logging in using your gmail address?
That’s what you used when you setup your Rhino account.

Yep I am, that is also what is on the “Login as Scott…” button on the image above. I also removed the license completely from my account and re-set it up using the “enter your license key” option form the image shown in the above post. That worked but then went back to the first screen “Retrieving license…” and the cycle continues.

Is it possible you’re behind a tightly configured firewall of some kind?
I know Hewlett Packard can’t use the Cloud Zoo for that reason.
There are a couple others but it’s pretty rare.

We run Dell Servers and nothing has changed per my IT guy. I used Rhino a week ago.