Rhino Licensing UI Changes

In today’s Rhino WIP, I’ve introduced a large number of changes to streamline and simplify the licensing process in Rhino. Everyone with an existing Rhino WIP should be prompted to enter their license again because the way the licenses are saved has changed.


  • Login to Rhino is more prominent
  • When entering a standalone license, Rhino will ask you to register and validate at the time you enter your license. Previously, validation happened separately and was confusing for many users.
  • License validation is more persistent, making sure you actually complete the process before the license validation grace period expires.
  • Zoo server selection is simpler and requires less clicks
  • Changing your license key from Tools->Options->Licenses uses the same process as when you enter a license for the first time.

Please let me know if you see anything strange or confusing in this process.

No problems so far, except:
It would be good if the dialog would show up on the main monitor.
I didn’t see the dialog on the same monitor where Rhino V6 started before…


Thanks, logged as RH-37552.

So, the autodownload failed here - I had to manually download this one. I was a bit surprised to find the installer simply ran without first having to enter a license key, but then saw that the licensing dialog came up after the install finished.

Out of curiosity I first tried the “cloud zoo” option, but I sorta figured it would fail - I guess I don’t have anything in there currently - don’t really know how to set that one up or if I should…

The “Rhino needs a license” dialog came up again after the above failed and simply entering my license key worked fine. So looks like it’s working as it should, in my case anyway.


No problems here. Worked fine.

Failure here…
It couldn’t connect to the online licensing thingy (as expected, these never work as we’re behind a proxy script).
I don’t know if I did something wrong, maybe not using the same email address, but now I’m kinda blocked…

Marc, it appears from your message you sent to our tech support team, that when you entered your license key you forgot the ‘@’ sign in your email address. I just fixed the bug that allowed you to enter an email address that isn’t valid for next week’s WIP.

Thanks Brian.
There was more to it than this, but we got Rhino to work.

I’m trying to install the current WIP.
At some point it asks to login to my McNeel account. I do so and click on “Accept” and I then get this message:

After that, it can’t connect to the validation server, so I get the validation code manually.
On the validation page it says Rhino 5 instead of 6 or VIP:

And then it doesn’t work.
This time there’s no “@” missing in my email address and the validation code was freshly generated…


I wasn’t paying attention when it updated the other day but I didn’t have to input my license number again… I think something appeared about zoo and I clicked a few things and it’s running fine?

How can I send you some info to tell you what I did?

The main ting is it’s telling me I’m up to date but I haven’t dug out the number and input it…



Hi Marc,

It sounds like your corporate firewall isn’t letting you access the Rhino Accounts login nor the Cloud Zoo, and the license entry UI isn’t working very well in that case. Logged as RH-37674.

I think the best thing to do here is to delete your license file and then click “Enter a license key” instead of “Login” when you are prompted for a license.

To delete your license file, browse to %programdata%\mcneel\rhinoceros\license manager\licenses and delete the file in there.

Hi Brian,
Just tried that. Still get this window:

But then Rhino started and seems fine…

Offline validation isn’t working in the build you have. But there’s a new one coming in about an hour that should fix the bug.

Ok, thanks.

The new build is out now. Please give it a try.

Still not really ready for prime time, but it does work, after much waiting, anxiety and frustration.

  1. Wherever a license key is requested, whether from within Rhino or the various places on your website, you provide a textbox for entry which will take whatever the user types and turn it into a properly formatted key. You obviously know how, so why don’t you do it for the validation code when Rhino is asking for it? A user accustomed to just jamming in lower case letters with no hyphens for a license key, when confronted with the validation code entry and discovering no editing, has to ask himself: Must I use uppercase? Must I use hyphens? If you have some important reason why you can’t edit the validation code on entry, then at least supply some explicit verbiage on the website code producing page and the code-entry window in Rhino specifying the exact format required.

  2. The validation workflow for an offline installation sucks like an Electrolux. The first box that appears upon first run after installation is what I take to be the same one used for online and it waits forever for a network connection. After some time waiting the underlying Rhino pops up a box that says it couldn’t find a license and is quitting. When the user says OK to this, the validation box quits right along with Rhino. If, before quitting Rhino, the user clicks “continue” on the validation form nothing happens.

The second time after installation that the user starts Rhino a different validation window pops up which gives the user the choice of manual validation. This is the one which should appear the first time, with a click on the manual choice interrupting the search for a net. As it is, if the manual choice is selected on this second-run box, and the user is careful to use the validation code EXACTLY as presented on the website (capital letters and hyphens), the validation is accepted and successful. I didn’t test to see what happens if the validation code is entered with lowercase or lacking the hyphens.

Hopefully you can polish this up some more. Right now the offline user will not be immediately productive after installation and validation because he/she will need a long session at the local pub to recover. Probably a hot shower to wash off the cold sweat too.

Added later: Another approach to the initial validation box might be to wait no more than 5-10 seconds for a network response and then put up a “Network not responding. Do you want to validate manually?” request.

Hi Al, thanks for all this great feedback. I’ve logged RH-37693 to provide a formatted text entry box for the validation code.

Yeah, I’m not sure what a reasonable timeout is. Perhaps 7 seconds is long enough to wait for modern internet connectivity. I’m surprised that on your system the system doesn’t notice that you’re offline immediately - on my computer with my network connection disabled, there is virtually no wait time. But if you have an enabled local internet connection but no internet, I can see how it’d time out. I’ll see if I can make the timeout shorter. Logged as RH-37694.

That’s strange - do you see both the license validation dialog which is trying to connect to our servers, and the “can’t find a license, Rhino will close” message at the same time?

The flow is supposed to go like this:

  1. You enter your license and email address
  2. Rhino tries to connect to our servers
  3. If it fails, it gives you two options: Try Again and Get a validation code manually.
  • If you click Try Again, you go back to step 2.
  • If you click Get a validation code manually, the next screen explains how to get a validation code from our website.
  1. If you don’t finish validation, but have clicked Get a Validation Code Manually, then Rhino will remember you did, and take you to the “Enter your validation code” page the next time it asks (without making you wait for the network check again).

I can’t tell from your description if something is going wrong between (2) and (3) or between (3) and (4).

I get these two at the same time:

I can’t click on “Continue” and clicking on “OK” closes the two windows… leaving the user… perplexed!

And now, when trying to get a validation code from the website, I get this message:
The license key RH?B-XXXX-XXXX-XXXX-XXXX-XXXX has been validated too many times and cannot be validated again.

Please help me @brian, this comes at a pretty bad time…

Like Marc said (and showed) in his post.

Between 3 and 4. Actually, it seems like it never fails.