Can not retrive Rhino 6 license from License Manager

I’ll send a message to the CZ developer to see if there’s anything odd he can see on our end.

What service release of Rhino V6 are you running?

Hello again @sdoe73,

If you put the license back on your account and then restart your computer, does that do anything for you?

Version 6 SR12
(6.12.19029.6381, 1/29/2019)

We’re on SR13 now but SR12 isn’t that old.
Did rebooting help?

Its Working.

As I was getting ready to restart I decided to click the login button again and went through that process (through MS edge browser) and it apparently worked this time.

Sorry for the trouble, Thanks for the help.

What browser were you using before?
We mostly use Chrome around here but it shouldn’t matter.

Please keep an eye on it by every few days, go into Options > Licenses.
Your off-line access should be about 2-weeks out and will keep refreshing when your off-line time is depleted by 10% or more.

If it’s not refreshing, then there is a problem.

FYI Every 3 months this licensing is being an issue for me. It warns me in advance but I always end up with some issues having to restart my computer after some fiddling or something.
It starts with me trying to open a new rhino window I get this which keeps loading and doing nothing.
image
Trying to close that window after minutes of waiting brings me to this:


“Login as siemen” brings me back to the eternal loading window which I try to close again. Then the same “licensing” window pops up again. I try to click on “x” to just close it and the eternal loading window pops up again. I close it again, I get the licensing window again. After 3 or 4 of this repetitive behaviour which I cannot get out of I get an Error message saying “Rhino needs a license to run, Rhino will close now”.
I’ll try to remember to screen record next time this happens.

What fixed it now was closing all Rhino windows I had open and tried again and now it works.

Hei Siemen - the fact that it happens every 3 months sounds like the login into your Rhino Account having expired. That part is as it should be but you should get a dialog up telling you about that. Did you ever try “Logout” on that “Rhinoceros 6 Needs a License” dialog?

Do I understand this right that you have one or more Rhino’s running and when you then start a new Rhino instance, you get the license issue? I’m wondering if there was a dialog box somewhere that was hidden by other applications…

CC: @aj1, @brian

No, never tried that I think. I’ll try it out next time.

I think so yes. I almost always have several Rhino’s running.

@siemen I have seen this before on Win7. Sometimes, for reasons unknown to me, there are “secret” Rhinos running in the background. Going to task manager and killing them seems to solve it (Which is essentially what you are doing by restarting your PC).

I am also having trouble. Every time I open Rhino, I get the message, “retrieving license from license manager”. After about 15min of loading, I am given the option of logging in, entering a license key, etc. I have tried both logging in with my account and entering a license key, but neither works. When I log in to my account, there is another long loading screen (5-10min), after which I am returned to the same menu. When I enter a license key, it logs me in to the mcneel website where I can see that there is the license associated with my account.

Thus there is no reason for issues logging in. I just tried updating Rhino to the newest version (Version 6 SR16, 2019-07-09), but still no luck.

Try restarting Windows.
Does that get you sorted?
I suspect there is a Windows service that is horked up.
Restarting Windows should sort it.

Any luck?

I’ve got this happening again. I tried to open another window of Rhino, while I’m already running 3 windows of rhino.

I just tried it and the same loading window as I get when trying to login pops up with nothing happening.
image

In applications in the task manager I see 3 Rhino tasks that are running, which is correct. Where should I see those hidden Rhinos?

@siemen have you tried installing Win 7 updates and/or restarting your computer?

No, and probably doing that will fix it. It’s just annoying that it randomly happens. I was in the middle of a meeting with a client. Not really professional to have to restart my computer and wait for updates to finish while trying to discuss a project.

Is there a way to turn of any windows updates that cause this to happen? And is it a bad idea?

FYI pt2, I was working today at a maker-space on one of their computers where they have a few rhino licenses and had the same problem happening with the unresponsive loading window when trying to login. Restarting windows didn’t fix it. After numerous attempts of trying to logout and login in rhino and via the website it eventually somehow worked (still don’t know what fixed it) but man what a pain this is.

This might be one of the first time I’m dealing with a rhino license that’s not my own. So either I’ve just been very unlucky with dealing with Rhino licenses or this painful process is happening in a lot of places. Anyway, you might already be tired of me posting here but I just keep informing you guys when I see this happening so you actually know this (still) happens.

1 Like

@aj1
Does this sound like a “stuck” Cloud Front cache to you?
If so, is there some other way to force a refresh?

I’m afraid it might be the latter…

@siemen this is caused by a semaphore issue inside the Windows OS. Currently the only way to fix it is to logout and login of your Windows machine (or restart your computer, which accomplishes the same thing). I am looking at ways of mitigating this in V6, and looking for an alternate way to deal with this altogether in V7. The Mac versions should not be affected by this problem.

Yes, often restarting windows fixes it, but as stated it wasn’t fixing it yesterday. It still took quite a few attempts of trying to log out and into the rhino license before I could start using Rhino.