More "retreiving license from manager..." garbage :-(

“garbage” to put it politely…

Have one Rhino instance open - says it got the license from my account this morning at 9:48


I am logged into my Rhino Account, licenses are available

But, I CANNOT open another Rhino instance… Endless "Retreiving license from license manager… "


Followed by


Cancel one, goes back to the other, constantly…

Can’t logout or do anything…

I am afraid to close the one instance I have running as if I can’t re-open Rhino on this machine I’m stuck…

On my laptop it gets a license no problem - so the system is not down. WTF?

@brian, @aj1 FYI

I finally had to resolve this by closing Rhino and restarting the computer… Fortunately it went back to normal (phew, I have a deadline tomorrow), no idea what actually caused it though.

This is an intermittent problem with Windows.
Rhino is asking the default Internet browser to go to the license site. and Windows has gone deaf.
The “fix” is to reboot the computer.
You might be able to clear the browser cache and avoid a restart, but I’ve not run into the problem myself.
@aj1 is trying to design a work-around for this Windows failing.

OK, sorry, if I wasn’t in such a panic today, I wouldn’t have even bothered you guys… Cheers.

It’s an occasional problem. You may never see it again. We don’t know under what circumstances Windows ignores the request. AJ says it’s a Windows “semaphore” thing.

No that ‘ocassional’ at all. It happening to me quite often but I figured long time ago to kill the Win session.

That’s interesting. I wonder what is different or special about your setup so that it happens more often.
Do you have lots of Rhino sessions running concurrently?
Maybe lots of browser windows open?
Know that it’s browser related, have you tried anything?

First of all: Bootcamp on a MBP.
I often need more than 1 session, but never goes more than 3 at the time.
One browser - Chrome with multiple tabs open.

That all sounds fine.
Bootcamp is a bit of a technical mess, but it’s generally manageable.
Chrome is our primary browser at McNeel.
How often do you reboot Windows?
Is Windows up to date?

I update Rhino on a weekly basis and reboot system daily, at least once.
I don’t make a big fuzz out of it because I know how to handle the problem, therefore i don’t record events.
Next time it happens I will let you know.

That sounds fine too.
Since we think the problem is browser related, try making some change in how you operate, like reducing (or increasing) the number or tabs you have open in the browser. Does the problem get better or worse?
Maybe temporarily switch to a different default browser like Edge (yuck. It’s a test okay?), just to see what happens.

Gosh! Is anyone using Edge at all?
I will keep my eyes open. Thanks for the tip.

I use FireFox exclusively. Never a problem.

Firefox here too for the most part (it’s default) - first time it happened here though.

I use FireFox exclusively. Had a lot of problems with the license thing, as described in this topic (among others) .

Perhaps it could be useful to show the need to restart your computer in case things don’t work or something?

FireFox with NoScript and other blockers here on both Windows and MacOS. Links want to open in the default container, but I have separate containers for separate users, so need to juggle a bit with reopening authentication link into proper container. Still temporarily allow loading of pages from localhost. Other than that it has worked.

Got the ol’ infinite loop “Retreiving license…” today again…

1 Like