Bug Report - Wenatchee 5 Build 2014-01-28 - Load Problem


#1

I’ve run into a perplexing problem. When I try to open a drawing (3dm format), Rhino draws the window and the first frame of the “zoom” (the cool UI it uses to show loading the geometry) and hangs with the spinning feedback icon. No amount of time lets it load (overnight). I can close the window and quit Rhino. If I try to open another drawing quickly, same thing happens. If I wait a few minutes, it will load the drawing.

Interstingly, when I first installed this release I had loaded 6 drawings without problem. Now I can only load a or 2 before this occurs. The other drawings are fine and I can edit them.


#2

Same problem here. I can not open any of the files I was working on. I tried to re-open the previous version of Rhino and I lost the view of the instruments. But at least I can continue working. If the previous version expires are in big trouble …


#3

I had the same, in the “old” version go to “Window”-> show main tool palette :wink:


#4

And the same for object snaps “Window”-> show object snaps


#5

same problem of Michael. I reinstalled old version too


#6

I’m working on Goggle Drive’s folder…


#7

This happens if I use File->Open, File->Open Recent or if i double click the file icon in the finder. These are all files on my local disk.

Oddly, things seemed fine yesterday when I first installed the release. I had 6 files open and was closing and opening files and then this issue kicked in. It now happens all the time.


#8

I also can’t duplicate file o rename


#9

I reset UI on a custom theme, with command prompt in previous style (not in in the fixed side bar).
Nothing else strange from usual work…


(Marlin Prowell) #10

I cannot duplicate any of this behavior, and I need to duplicate it to be able to find it and fix it. Please tell me absolutely everything you can about what you are doing. Michael_Hackney’s description of how he is opening files and where the files are located are important facts to tell me. Tell me lots more.

Please post your OpenGL settings so I can see your hardware and software environment.

Is anyone running in full screen mode? Perhaps this is blocking a dialog from showing up.

Is it always the same files that never open, and other files always open?


#11

Marlin, I can reproduce this 100% on my mac (running 10.9.1) - 2.9GHz, intel core i5, 32 GB RAM, Fusion drive.

I’ve tried opening files I’ve created in previous versions and in this release and they all stall on opening. Here is a screenshot of what the window looks like. Once I get this, I can not close the window. I can work in other windows if they are opened correctly. The only way to get out is to quit Rhino.

I am not running full screen. And every file I have (all of the 75 I’ve checked) created in Mac and Windows versions of Rhino exhibit the same problem.


#12

Update. Once you have opened the file I was working with the previous version of Rhino, I opened the 01-28-2014 and now the files are opened. I do further testing.


#13

is that a 21" imac?
fwiw, you should go Rhinoceros-> Preferences-> OpenGL…
at the bottom of the window, click 'copy to clipboard’
paste the info here.


#14

When this happens to one of my files (it won’t open), if I try it again later it will open again fine. Sometimes it will open, sometimes it won’t but I am getting consistent opening failures.

As I stated above, when I first installed this release it was opening and closing files with no problems - dozens of times. Then I had to restart Rhino because of the persistent tool panel bug I reported and this started showing up.


#15

maybe the .plist corrupted during a force quit?

you could try deleting it which will return rhino to its default (fresh install) state.

quit rhino
go to: ~(user)/ Library/ Preferences
find the file com.mcneel.rhinoceros.plist and move it to the trash.
launch rhino.

(if your user library is hidden, click the finder icon in your dock… click the GO menu at the top of your screen… press and hold the option key… an item ‘Library’ will appear… that’s your user library so click it then go to the Preferences folder)


that said, i know mavericks has some new behaviors regarding .plists and i’m not entirely sure if you can reset an app this way as you’ve been able to do in the past… i haven’t tested it with rhino/mavericks so maybe wait for marlin to advise on how to uninstall / reinstall rhino in mavericks.


#16

Jeff, I deleted the plist file and the problem still presents itself. I should also say, I quite gracefully using the Quit menu, no force quit was required.

What is the com.mcneel.LSSharedFileList.plist in the preferences folder?


#17

yeah, i just tried deleting the .plist too (well, moved mine to the desktop as i don’t want to delete it) but it didn’t reset… all of my macros and shortcuts and window arrangements etc were the same… i read about this briefly the other day but again, haven’t really investigated… mavericks keeps a copy (or something) of the .plists and i guess it’s a convoluted process to really delete them and start fresh.
not sure why apple has done this but i’ll go ahead and assume they had a good reason.


#18

I have the same problem. I downloaded and installed the 2014-01-28 build yesterday (Jan 28) and worked on several files for a couple of hours with no problem. Today I was able to open of them. And then I decided to rename some of the files (I’m not sure if this is related). I simply changed the name of the file in the finder window (for example, from JamesBayVillage_03.3dm to ConceptModel_01.3dm). I was able to reopen the ConceptModel_01.3dm and make some changes but then after about 20 minutes all of the commands stopped working. I would click on the Line or Polyline or Rectangle icon from the left sidebard menu. I can move my cursor around but no snaps were showing up so I couldn’t enter the first point using the cursor to start the command. I close the window and then restarted Rhino. After that I was not able to load any of the files. It hangs at start-up. I’ve attached a screenshot.

Here is my info from the OpenGL window:

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-01-28 (498)
OS X version: Version 10.9.1 (Build 13B3116)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4960HQ CPU @ 2.60GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1440 x 900
Displays: Color LCD

USB devices
Apple: Internal Memory Card Reader
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Tablet: PTK-440

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.20.15 310.40.15f03
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: None
Mip map filtering: None
Anisotropic filtering: None

I am going to try to revert back to the previous build because I need to get work done.

Please do not expire the previous build until this is fixed. The current new build is unusable as is.


(Marlin Prowell) #19

The technique Jeff mentions (and which I have suggested in the past) no longer works in Mavericks. OS X keeps a secret copy of Rhino’s preferences somewhere and puts back any .plist file you delete.

There is a different way to reset your preferences that works with all versions of OS X, including Mavericks, and I’ve updated the Wiki page that describes how to reset Rhino’s preferences.

When you see the Loading view, Rhino is both reading the 3DM file and it is also recreating any render meshes that are necessary to display the model. Are you in the habit of using SaveSmall? This will discard any render meshes when saving and always force Rhino to rebuild render meshes at start and this might be a factor.

@Michael_Hackney, can you zip one of your models that hangs at open and email it to me at marlin@mcneel.com? I’d like to see if I can duplicate this problem here.

Another test: the previous non-single-window UI still lurks in Mac Rhino. Type TestSingleWindowModeling, quit and restart Rhino. The previous UI should be back. Do these files still hang? This will help me figure out if this is related to single window modeling or if it is something else entirely.


#20

I emailed you a file Marlin. I’ll try the other items in your reply soon and report back.

No, I am not using SaveSmall.

Regards,
Michael