Not opening file

The window keeps showing the loading screen, even though I can already toggle on/off windows from the menu dropdown. I had it loading more than an hour, it will not finish.
Attached also a strange situation with the loading window still there in the window, but at the same time the working window where I could actually click on things and change settings.

Hi - does this happen for one particular file or generally for all files?
Please run the SystemInfo command and post the results here. If you have a 3dm file that reproduces that issue on your end, please also post that.

It’s only that file. I tried Audit, Audit3dmfile, opening on another computer. Just exporting it to a Rhino 5 file, opening it there and then opening it again with Rhino 6 worked.

I uploaded the file through your form already if you want to check that.

Rhino 6 SR19 2019-10-22 (Public Build, 6.19.19295.01282, Git hash:master @ 0af62045bd35259d4c2367dbf7f9ef94ded29299)
License type: Educational, build 2019-10-22
License details: Cloud Zoo. In use by: Nils Köpfer ()

Apple Intel 64-bit macOS Version 10.13.6 (Build 17G8037) (Physical RAM: 40Gb)
Mac Model Identifier: iMac18,3
Machine name: AtelierKanal_5
Language: en-BE (MacOS default)

AMD Radeon Pro 580 OpenGL Engine (OpenGL ver:4.1 ATI-1.68.23)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB
Graphics: Radeon Pro 580
Displays: iMac (217dpi 2x)

Graphics processors
Radeon Pro 580 (8192 MB)
iMac (2560 x 1440)

USB devices
Broadcom Corp.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Logitech: USB Optical Mouse

Bluetooth devices
Broadcom: Magic Keyboard with Numeric Keypad

Third party kernel extensions
org.pqrs.driver.Karabiner.VirtualHIDDevice.v061000 (6.10.0) 4D004D1A-ED2F-3780-AD53-A10F286EC759

Third party plugins

Rhino plugins
/Applications/ “RhinoCycles” 6.19.19295.1282
/Applications/ “Snapshots” 6.19.19295.1002
/Applications/ “Rhino Bonus Tools” 6.19.19295.1002
/Applications/ “Grasshopper” 6.19.19295.1282
/Applications/ “PanelingTools” 6.19.19295.1002
/Applications/ “Commands” 6.19.19295.1282
/Applications/ “RDK_EtoUI” 6.19.19295.1282
/Applications/ “BlockEdit” 6.19.19295.1282
/Applications/ “Displacement” 6.19.19295.1002
/Applications/ “IronPython” 6.19.19295.1282
/Applications/ “Rhino Render” 6.19.19295.1002
/Applications/ “AnimationTools” 6.19.19295.1002
/Applications/ “Renderer Development Kit” 6.19.19295.1002

Hi - thanks for that file! There was an issue (RH-55580) with dealing with multiple viewports correctly.
This has been fixed for the upcoming 6.21 (for which a Release Candidate is now available) and 7.0 WIP versions.
[Fun fact - I have a brother who works right across the canal from that building ;]

1 Like

Is this bug persistent in 6.20.19323.01022?

I just updated from 6.19 to 6.20.19323.01022 and performance is impressively slow. I face the the same behavior @atelierkanal is describing, with the difference that if I wait long enough the file finally opens.
However, even creating a blank new document takes a minute.

what is your estimate V 6.21 is released? Currently I cannot use Rhino on Mac …

Hi - this sounds like something completely different.
Can you please post a file that is giving you problems?
Also, are you saying that performance of 6.20 is worse than 6.19?
Please run the Rhino SystemInfo command and post the result here.

This should be fixed in the latest Release Candidate for Rhino 6 for Mac 6.21.